p PatchFirst

CVE-2026-54328

CVE-2026-54328 · Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.

CVSS 7.3 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • pi

    Softwareversionen
    • >= 0.74.0, < 0.78.1: Betroffen

    Keine Korrektur veröffentlicht

  • @earendil-works/pi-coding-agent npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.74.0, < 0.78.1

    Auf 0.78.1 aktualisieren

  • @mariozechner/pi-coding-agent npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.50.0, ≤ 0.73.1

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →