p PatchFirst

CVE-2026-54338

CVE-2026-54338 · JupyterHub: Unauthenticated Denial of Service via Unbounded Username Logging on Failed Login

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. Prior to 5.5.0, invalid input to form-based login authenticators can place an unbounded attacker-controlled username in failed-login logs, allowing an unauthenticated attacker to consume logging and storage resources. This issue is fixed in version 5.5.0.

CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • jupyterhub

    Softwareversionen
    • < 5.5.0JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. Prior to 5.5.0, invalid input to form-based login authenticators can place an unbounded attacker-controlled username in failed-login logs, allowing an unauthenticated attacker to consume logging and storage resources. This issue is fixed in version 5.5.0.: Betroffen

    Keine Korrektur veröffentlicht

  • jupyterhub Debian:12

    Softwareversionen
    • 3.0.0+ds1-1
    • 5.0.0+ds1-1
    • 5.0.0+ds1-2
    • 5.0.0+ds1-3
    • 5.0.0+ds1-4
    • 5.2.1+ds1-1
    • 5.2.1+ds1-2
    • 5.2.1+ds1-3
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub Debian:13

    Softwareversionen
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub Debian:14

    Softwareversionen
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub PyPI

    Softwareversionen
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.4.1
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.7.0
    • 0.7.0b1
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.0b1
    • 0.8.0b2
    • 0.8.0b3
    • 0.8.0b4
    • 0.8.0b5
    • 0.8.0rc1
    • 0.8.0rc2
    • 0.8.1
    • 0.9.0
    • 0.9.0b1
    • 0.9.0b2
    • 0.9.0b3
    • 0.9.0rc1
    • 0.9.1
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.6
    • 1.0.0
    • 1.0.0b1
    • 1.0.0b2
    • 1.1.0
    • 1.1.0b1
    • 1.2.0
    • 1.2.0b1
    • 1.2.1
    • 1.2.2
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 2.0.0
    • 2.0.0b1
    • 2.0.0b2
    • 2.0.0b3
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.0rc3
    • 2.0.0rc4
    • 2.0.0rc5
    • 2.0.1
    • 2.0.2
    • 2.1.0
    • 2.1.1
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 3.0.0
    • 3.0.0b1
    • 3.1.0
    • 3.1.1
    • 4.0.0
    • 4.0.0b1
    • 4.0.0b2
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.4
    • 4.1.5
    • 4.1.6
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.1.0
    • 5.2.0
    • 5.2.1
    • 5.3.0
    • 5.3.0rc0
    • 5.4.0
    • 5.4.1
    • 5.4.2
    • 5.4.3
    • 5.4.4
    • 5.4.5
    • 5.4.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.5.0

    Auf 5.5.0 aktualisieren

  • jupyterhub Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0+ds1-1
    • 2.0.0+ds1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub Ubuntu:24.04:LTS

    Softwareversionen
    • 3.0.0+ds1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub Ubuntu:26.10

    Softwareversionen
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterhub Ubuntu:26.04:LTS

    Softwareversionen
    • 5.2.1+ds1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →