p PatchFirst

CVE-2026-54627

CVE-2026-54627 · SAIL: Heap out-of-bounds write in SAIL PSD decoder (Bitmap mode ignores depth)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

SAIL is a cross-platform library for loading and saving images with support for animation, metadata, and ICC profiles. In 0.9.10 and earlier, psd_private_sail_pixel_format() in src/sail-codecs/psd/helpers.c resolves a one-channel PSD in Bitmap color mode to SAIL_PIXEL_FORMAT_BPP1_INDEXED without requiring the file depth to be one, so the pixel buffer uses one-bit rows while sail_codec_load_frame_v8_psd() in src/sail-codecs/psd/psd.c accepts depth == 8 and writes one attacker-controlled byte per pixel. Loading a crafted PSD through sail_load_from_file() or sail_load_from_memory() therefore writes beyond each heap row, causing memory corruption, a reliable crash, or potential code execution. This mode/depth mismatch is distinct from GHSA-rcqx-gc76-r9mv and GHSA-wcj8-hxxf-pq2c. This issue is fixed in version 1.0.0.

CVSS 9.8 · Kritisch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • sail

    Softwareversionen
    • < 1.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • sail Debian:13

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.10-3
    • 0.9.8-1
    • 0.9.8-1+deb13u1
    • 0.9.9-1
    • 1.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • sail Debian:14

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.10-3
    • 0.9.8-1
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2.0-1

    Auf 1.2.0-1 aktualisieren

  • sail Ubuntu:24.04:LTS

    Softwareversionen
    • 0.9.0+repack-1
    • 0.9.0+repack-2
    • 0.9.0+repack-2.1
    • 0.9.0+repack-2.1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • sail Ubuntu:26.10

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • sail Ubuntu:26.04:LTS

    Softwareversionen
    • 0.9.9-1
    • 0.9.10-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →