p PatchFirst

CVE-2026-55863

CVE-2026-55863 · motionEye: Missing authentication on ActionHandler allows unauthenticated camera action execution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

motionEye (mEye) is an online interface for a piece of software called "motion," which is a video surveillance program with motion detection. Prior to 0.44.0, the ActionHandler.post() method in motioneye/handlers/action.py lacks the BaseHandler.auth() decorator, allowing an unauthenticated remote attacker to send requests to /action/<camera_id>/<action>. The endpoint can trigger snapshot, record_start, and record_stop actions. When an administrator has configured action scripts, the same endpoint can invoke PTZ controls, alarm actions, lighting actions, and other predefined commands, and configured remote motionEye cameras can allow server-side requests to the remote camera service. This issue is fixed in version 0.44.0.

CVSS 5.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • motioneye

    Softwareversionen
    • < 0.44.0: Betroffen

    Keine Korrektur veröffentlicht

  • motioneye PyPI

    Softwareversionen
    • 0.27
    • 0.27.1
    • 0.27.2
    • 0.28
    • 0.28.1
    • 0.28.2
    • 0.28.3
    • 0.29
    • 0.29.1
    • 0.29rc1
    • 0.29rc2
    • 0.30
    • 0.30rc1
    • 0.30rc2
    • 0.31
    • 0.31.1
    • 0.31.2
    • 0.31.3
    • 0.31.4
    • 0.31.5
    • 0.32
    • 0.32.1
    • 0.32.2
    • 0.33
    • 0.33.1
    • 0.33.2
    • 0.33.3
    • 0.33.4
    • 0.34
    • 0.34.1
    • 0.34rc1
    • 0.35
    • 0.35.1
    • 0.35.2
    • 0.35rc1
    • 0.36
    • 0.36.1
    • 0.37
    • 0.37.1
    • 0.37rc1
    • 0.38
    • 0.38.1
    • 0.39
    • 0.39.1
    • 0.39.2
    • 0.39.3
    • 0.40
    • 0.40rc1
    • 0.40rc2
    • 0.40rc3
    • 0.40rc4
    • 0.40rc5
    • 0.41
    • 0.41rc1
    • 0.42
    • 0.42.1
    • 0.43.1
    • 0.43.1b1
    • 0.43.1b2
    • 0.43.1b3
    • 0.43.1b4
    • 0.43.1b5
    • 0.44.0b1
    • 0.44.0b2
    • 0.44.0b3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.44.0

    Auf 0.44.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →