p PatchFirst

CVE-2026-57480

CVE-2026-57480 · Parse Server: Denial of service via exponential-time processing of deeply nested query operators

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • parse-server

    Softwareversionen
    • >= 9.0.0-alpha.1, < 9.9.1-alpha.12: Betroffen
    • < 8.6.82: Betroffen

    Keine Korrektur veröffentlicht

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.0.0, < 9.9.1-alpha.12

    Auf 9.9.1-alpha.12 aktualisieren

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: < 8.6.82

    Auf 8.6.82 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →