p PatchFirst

CVE-2026-57488

CVE-2026-57488 · pupnp: Integer truncation in HTTP Content-Length parsing enables request smuggling

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

pupnp is an SDK for development of UPnP device and control point applications. Prior to 2.0.2, raw_to_int in upnp/src/genlib/net/http/httpparser.c parses Content-Length with strtol and casts the resulting long to a 32-bit int before the caller stores it as unsigned int. On LP64 systems, values greater than INT_MAX can truncate or wrap, so the HTTP parser can accept a body length different from the declared value. A remote adjacent-network peer can use the resulting parser disagreement to leave bytes to be interpreted as another request in persistent or proxied contexts, or can make a worker wait for an extremely large body and cause denial of service. This issue is fixed in 2.0.2.

CVSS 7.1 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • pupnp

    Softwareversionen
    • < 2.0.2: Betroffen

    Keine Korrektur veröffentlicht

  • pupnp Debian:13

    Softwareversionen
    • 1:1.14.20-1
    • 1:1.14.20-1+deb13u1
    • 1:1.14.23-1
    • 1:1.14.24-1
    • 1:1.14.24-2
    • 1:1.14.24-3
    • 1:1.14.25-1
    • 1:1.14.31-1
    • 1:1.18.0-1
    • 1:1.18.4-1
    • 1:1.18.5-1
    • 1:22.1.8-1
    • 1:22.1.8-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp Debian:14

    Softwareversionen
    • 1:1.14.20-1
    • 1:1.14.23-1
    • 1:1.14.24-1
    • 1:1.14.24-2
    • 1:1.14.24-3
    • 1:1.14.25-1
    • 1:1.14.31-1
    • 1:1.18.0-1
    • 1:1.18.4-1
    • 1:1.18.5-1
    • 1:22.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:22.1.8-2

    Auf 1:22.1.8-2 aktualisieren

  • libupnp Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1:1.6.19+git20141001-1
    • 1:1.6.19+git20141001-1ubuntu1
    • 1:1.6.19+git20160116-1
    • 1:1.6.19+git20160116-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mediatomb Ubuntu:16.04:LTS

    Softwareversionen
    • 0.12.1-47-g7ab7616-1ubuntu1
    • 0.12.1-47-g7ab7616-1ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libupnp Ubuntu:18.04:LTS

    Softwareversionen
    • 1:1.6.22-1
    • 1:1.6.24-1
    • 1:1.6.24-2
    • 1:1.6.24-3
    • 1:1.6.24-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp-1.8 Ubuntu:18.04:LTS

    Softwareversionen
    • 1:1.8.2-2
    • 1:1.8.2-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp-1.8 Ubuntu:20.04:LTS

    Softwareversionen
    • 1:1.8.4-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp-1.8 Ubuntu:22.04:LTS

    Softwareversionen
    • 1:1.8.4-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp Ubuntu:24.04:LTS

    Softwareversionen
    • 1:1.14.18-1ubuntu1
    • 1:1.14.18-1.1ubuntu1
    • 1:1.14.18-1.1ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp Ubuntu:26.10

    Softwareversionen
    • 1:1.14.25-1ubuntu1
    • 1:1.14.31-1ubuntu1
    • 1:1.14.31-1ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pupnp Ubuntu:26.04:LTS

    Softwareversionen
    • 1:1.14.24-3ubuntu1
    • 1:1.14.25-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →