p PatchFirst

CVE-2026-58501

CVE-2026-58501 · Zeep SSRF because Settings.forbid_external is not enforced

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Zeep is a Python SOAP client. From 4.0.0 before 4.3.3, Settings.forbid_external is defined but not enforced when parsing WSDL or XSD documents, allowing transitive xsd:import, xsd:include, wsdl:import, and lxml entity or DTD references to fetch attacker-chosen HTTP or HTTPS URLs. This issue is fixed in version 4.3.3.

CVSS 5.9 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • python-zeep

    Softwareversionen
    • >= 4.0.0, < 4.3.3: Betroffen

    Keine Korrektur veröffentlicht

  • python-zeep Debian:12

    Softwareversionen
    • 4.2.1-1
    • 4.2.1-2
    • 4.2.1-3
    • 4.3.1-1
    • 4.3.1-2
    • 4.3.1-3
    • 4.3.2-1
    • 4.3.2-2
    • 4.3.2-3
    • 4.3.3-1
    • 4.3.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Debian:13

    Softwareversionen
    • 4.3.1-2
    • 4.3.1-3
    • 4.3.2-1
    • 4.3.2-2
    • 4.3.2-3
    • 4.3.3-1
    • 4.3.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Debian:14

    Softwareversionen
    • 4.3.1-2
    • 4.3.1-3
    • 4.3.2-1
    • 4.3.2-2
    • 4.3.2-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.3.3-1

    Auf 4.3.3-1 aktualisieren

  • zeep PyPI

    Softwareversionen
    • 4.0.0
    • 4.1.0
    • 4.2.0
    • 4.2.1
    • 4.3.0
    • 4.3.1
    • 4.3.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 4.3.3

    Auf 4.3.3 aktualisieren

  • python-zeep Ubuntu:18.04:LTS

    Softwareversionen
    • 2.1.1-1
    • 2.4.0-1
    • 2.5.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:20.04:LTS

    Softwareversionen
    • 3.2.0-1
    • 3.4.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:22.04:LTS

    Softwareversionen
    • 4.0.0-1
    • 4.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:24.04:LTS

    Softwareversionen
    • 4.2.1-1
    • 4.2.1-2
    • 4.2.1-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:25.10

    Softwareversionen
    • 4.3.1-2
    • 4.3.1-2ubuntu1
    • 4.3.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:26.10

    Softwareversionen
    • 4.3.2-1
    • 4.3.2-2
    • 4.3.2-3
    • 4.3.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-zeep Ubuntu:26.04:LTS

    Softwareversionen
    • 4.3.1-3
    • 4.3.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →