CVE-2026-59180
CVE-2026-59180 · Apprise forwards configured auth headers across cross-origin HTTP redirects
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.
CVSS 3.1 · Niedrig · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
apprise
- Softwareversionen
- < 1.11.0: Betroffen
Keine Korrektur veröffentlicht
apprise Debian:12
- Softwareversionen
- 1.10.0-1
- 1.11.0-1
- 1.13.0-1
- 1.2.0-1
- 1.4.0-1
- 1.4.0-2
- 1.4.5-1
- 1.5.0-1
- 1.6.0-1
- 1.7.1-1
- 1.7.2-1
- 1.7.4-1
- 1.7.5-1
- 1.7.6-1
- 1.8.0-1
- 1.8.0-1~bpo11+1
- 1.8.0-2
- 1.8.0-3
- 1.8.1-1
- 1.9.0-1
- 1.9.1-1
- 1.9.2-1
- 1.9.3-1
- 1.9.9-1
- 2.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
apprise Debian:13
- Softwareversionen
- 1.10.0-1
- 1.11.0-1
- 1.13.0-1
- 1.9.3-1
- 1.9.9-1
- 2.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
apprise Debian:14
- Softwareversionen
- 1.10.0-1
- 1.9.3-1
- 1.9.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.0-1
Auf 1.11.0-1 aktualisieren
apprise PyPI
- Softwareversionen
- 0.0.1
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- 0.5.0
- 0.5.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.7.7
- 0.7.8
- 0.7.9
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5.1
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.8.1
- 0.9.8.2
- 0.9.8.3
- 0.9.9
- 1.0.0
- 1.1.0
- 1.10.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.5
- 1.5.0
- 1.6.0
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.8.0
- 1.8.1
- 1.9.0
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 1.9.7
- 1.9.8
- 1.9.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.0
Auf 1.11.0 aktualisieren
apprise Ubuntu:24.04:LTS
- Softwareversionen
- 1.4.5-1
- 1.6.0-1
- 1.7.1-1
- 1.7.2-1
- 1.7.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
apprise Ubuntu:26.04:LTS
- Softwareversionen
- 1.9.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht