CVE-2026-59205
CVE-2026-59205 · Pillow: Controlled heap out-of-bounds write in `ImageCmsTransform.apply()` via output mode mismatch
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Pillow is a Python imaging library. Prior to 12.3.0, Pillow's ImageCms.ImageCmsTransform.apply(im, imOut) API can trigger controlled native heap corruption when the caller supplies an output image whose mode does not match the transform's declared output mode. This issue is fixed in version 12.3.0.
CVSS 7.5 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pillow
- Softwareversionen
- < 12.3.0: Betroffen
Keine Korrektur veröffentlicht
pillow Debian:12
- Softwareversionen
- 10.0.0-1
- 10.1.0-1
- 10.2.0-1
- 10.3.0-1
- 10.3.0-2
- 10.4.0-1
- 10.4.0-1.1
- 11.1.0-1
- 11.1.0-2
- 11.1.0-3
- 11.1.0-4
- 11.1.0-5
- 11.2.1-1
- 11.3.0-1
- 12.0.0-1
- 12.1.0-1
- 12.1.1-1
- 12.1.1-2
- 12.2.0-1
- 12.3.0-1
- 13.0.0-1
- 9.4.0-1.1
- 9.4.0-1.1+deb12u1
- 9.5.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Debian:13
- Softwareversionen
- 11.1.0-5
- 11.1.0-5+deb13u1
- 11.1.0-5+deb13u2
- 11.1.0-5+deb13u3
- 11.1.0-5+deb13u4
- 11.2.1-1
- 11.3.0-1
- 12.0.0-1
- 12.1.0-1
- 12.1.1-1
- 12.1.1-2
- 12.2.0-1
- 12.3.0-1
- 13.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Debian:14
- Softwareversionen
- 11.1.0-5
- 11.2.1-1
- 11.3.0-1
- 12.0.0-1
- 12.1.0-1
- 12.1.1-1
- 12.1.1-2
- 12.2.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 12.3.0-1
Auf 12.3.0-1 aktualisieren
pillow PyPI
- Softwareversionen
- 1.0
- 1.1
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 10.0.0
- 10.0.1
- 10.1.0
- 10.2.0
- 10.3.0
- 10.4.0
- 11.0.0
- 11.1.0
- 11.2.1
- 11.3.0
- 12.0.0
- 12.1.0
- 12.1.1
- 12.2.0
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 3.0.0
- 3.1.0
- 3.1.0.rc1
- 3.1.0rc1
- 3.1.1
- 3.1.2
- 3.2.0
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.4.0
- 3.4.1
- 3.4.2
- 4.0.0
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.3.0
- 5.0.0
- 5.1.0
- 5.2.0
- 5.3.0
- 5.4.0
- 5.4.0.dev0
- 5.4.1
- 6.0.0
- 6.1.0
- 6.2.0
- 6.2.1
- 6.2.2
- 7.0.0
- 7.1.0
- 7.1.1
- 7.1.2
- 7.2.0
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.3.0
- 8.3.1
- 8.3.2
- 8.4.0
- 9.0.0
- 9.0.1
- 9.1.0
- 9.1.1
- 9.2.0
- 9.3.0
- 9.4.0
- 9.5.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 12.3.0
Auf 12.3.0 aktualisieren
pillow Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2.2.1-1ubuntu2
- 2.2.1-2ubuntu1
- 2.2.1-3ubuntu2
- 2.2.1-3ubuntu3
- 2.2.1-3ubuntu4
- 2.2.1-3ubuntu6
- 2.3.0-1ubuntu1
- 2.3.0-1ubuntu2
- 2.3.0-1ubuntu3
- 2.3.0-1ubuntu3.2
- 2.3.0-1ubuntu3.3
- 2.3.0-1ubuntu3.4
- 2.3.0-1ubuntu3.4+esm1
- 2.3.0-1ubuntu3.4+esm2
- 2.3.0-1ubuntu3.4+esm3
- 2.3.0-1ubuntu3.4+esm4
- 2.3.0-1ubuntu3.4+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.9.0-1
- 3.0.0-1
- 3.0.0-1build1
- 3.1.0-1
- 3.1.1-1
- 3.1.2-0ubuntu1
- 3.1.2-0ubuntu1.1
- 3.1.2-0ubuntu1.3
- 3.1.2-0ubuntu1.4
- 3.1.2-0ubuntu1.5
- 3.1.2-0ubuntu1.6
- 3.1.2-0ubuntu1.6+esm1
- 3.1.2-0ubuntu1.6+esm2
- 3.1.2-0ubuntu1.6+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.1.1-3build2
- 4.3.0-2ubuntu1
- 5.0.0-1
- 5.1.0-1
- 5.1.0-1ubuntu0.2
- 5.1.0-1ubuntu0.3
- 5.1.0-1ubuntu0.4
- 5.1.0-1ubuntu0.5
- 5.1.0-1ubuntu0.6
- 5.1.0-1ubuntu0.7
- 5.1.0-1ubuntu0.8
- 5.1.0-1ubuntu0.8+esm1
- 5.1.0-1ubuntu0.8+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 6.1.0-1
- 6.1.0-1build1
- 6.2.1-2
- 7.0.0-4
- 7.0.0-4build1
- 7.0.0-4ubuntu0.1
- 7.0.0-4ubuntu0.2
- 7.0.0-4ubuntu0.3
- 7.0.0-4ubuntu0.4
- 7.0.0-4ubuntu0.5
- 7.0.0-4ubuntu0.6
- 7.0.0-4ubuntu0.7
- 7.0.0-4ubuntu0.8
- 7.0.0-4ubuntu0.9
- 7.0.0-4ubuntu0.9+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow-python2 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 6.2.1-3~build1
- 6.2.1-3
- 6.2.1-3ubuntu0.1~esm1
- 6.2.1-3ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:22.04:LTS
- Softwareversionen
- 8.1.2+dfsg-0.3
- 9.0.0-1
- 9.0.1-1
- 9.0.1-1build1
- 9.0.1-1ubuntu0.1
- 9.0.1-1ubuntu0.2
- 9.0.1-1ubuntu0.3
- 9.0.1-1ubuntu0.4
- 9.0.1-1ubuntu0.5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:24.04:LTS
- Softwareversionen
- 10.0.0-1
- 10.1.0-1
- 10.2.0-1
- 10.2.0-1build1
- 10.2.0-1ubuntu1
- 10.2.0-1ubuntu1.2
- 10.2.0-1ubuntu1.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pillow Ubuntu:26.04:LTS
- Softwareversionen
- 11.3.0-1ubuntu1
- 11.3.0-1ubuntu2
- 12.0.0-1ubuntu1
- 12.1.1-1ubuntu1
- 12.1.1-2ubuntu1
- 12.1.1-2ubuntu1.1
- 12.1.1-2ubuntu1.2
- 12.1.1-2ubuntu1.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-9hw9-ch79-4vh6
- https://github.com/python-pillow/Pillow/pull/9715
- https://github.com/python-pillow/Pillow/commit/a9ffc42bedf4fc0a7ef8d6486e7f9e81e3397721
- https://github.com/python-pillow/Pillow/releases/tag/12.3.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-59205