CVE-2026-59886
CVE-2026-59886 · pyasn1: Uncontrolled resource consumption when converting decoded REAL values
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the univ.Real type converted its mantissa, base, and exponent value to a Python float using exact big-integer exponentiation. A BER, CER, or DER encoded REAL value only a few bytes long can carry a very large exponent, causing float conversion through prettyPrint(), str(), comparison, arithmetic, int(), or an explicit float() call to consume excessive CPU and memory and hang applications that decode untrusted ASN.1 data and then print, log, or compare decoded objects. This issue is fixed in version 0.6.4.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pyasn1
- Softwareversionen
- < 0.6.4: Betroffen
Keine Korrektur veröffentlicht
pyasn1 Debian:12
- Softwareversionen
- 0.4.8-3
- 0.4.8-3+deb12u1
- 0.4.8-3+deb12u2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.4.8-3+deb12u3
Auf 0.4.8-3+deb12u3 aktualisieren
pyasn1 Debian:13
- Softwareversionen
- 0.6.1-1
- 0.6.1-1+deb13u1
- 0.6.1-1+deb13u2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.1-1+deb13u3
Auf 0.6.1-1+deb13u3 aktualisieren
pyasn1 Debian:14
- Softwareversionen
- 0.6.1-1
- 0.6.2-1
- 0.6.2-1~bpo13+1
- 0.6.3-1
- 0.6.4-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.4-1
Auf 0.6.4-1 aktualisieren
pyasn1 PyPI
- Softwareversionen
- 0.0.10a
- 0.0.11a
- 0.0.12a
- 0.0.13
- 0.0.13a
- 0.0.13b
- 0.0.6a
- 0.0.9a
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.1
- 0.2.2
- 0.2.3
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.4.5
- 0.4.6
- 0.4.7
- 0.4.8
- 0.5.0
- 0.5.1
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.4
Auf 0.6.4 aktualisieren
pyasn1 Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 0.1.4-0ubuntu1
- 0.1.7-1ubuntu1
- 0.1.7-1ubuntu2
- 0.1.7-1ubuntu2.1
- 0.1.7-1ubuntu2.1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyasn1 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.1.8-2
- 0.1.9-1
- 0.1.9-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyasn1 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 0.1.9-2
- 0.4.2-3
- 0.4.2-3ubuntu0.18.04.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyasn1 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 0.4.2-3
- 0.4.2-3build1
- 0.4.2-3ubuntu0.20.04.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyasn1 Ubuntu:22.04:LTS
- Softwareversionen
- 0.4.8-1
- 0.4.8-1ubuntu0.1
- 0.4.8-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.4.8-1ubuntu0.3
Auf 0.4.8-1ubuntu0.3 aktualisieren
pyasn1 Ubuntu:24.04:LTS
- Softwareversionen
- 0.4.8-4
- 0.4.8-4ubuntu0.1
- 0.4.8-4ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.4.8-4ubuntu0.3
Auf 0.4.8-4ubuntu0.3 aktualisieren
pyasn1 Ubuntu:26.04:LTS
- Softwareversionen
- 0.6.1-1
- 0.6.1-1build1
- 0.6.2-1
- 0.6.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.6.3-1ubuntu0.1
Auf 0.6.3-1ubuntu0.1 aktualisieren