p PatchFirst

CVE-2026-59926

CVE-2026-59926 · Mistune: XSS via unescaped class option in Admonition directive

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.2.1, render_admonition() in src/mistune/directives/admonition.py concatenates the Admonition directive :class: option into the HTML class attribute without escaping, allowing attribute injection and cross-site scripting even when HTMLRenderer escape mode is enabled. This issue is fixed in version 3.2.1.

CVSS 5.3 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • mistune

    Softwareversionen
    • < 3.2.1: Betroffen

    Keine Korrektur veröffentlicht

  • mistune Debian:13

    Softwareversionen
    • 3.1.3-1
    • 3.1.4-1
    • 3.3.4-1
    • 3.4.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Debian:14

    Softwareversionen
    • 3.1.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.4-1

    Auf 3.1.4-1 aktualisieren

  • mistune PyPI

    Softwareversionen
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.4
    • 0.4.1
    • 0.5
    • 0.5.1
    • 0.6
    • 0.7
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.7.4
    • 0.8
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 2.0.0
    • 2.0.0a1
    • 2.0.0a2
    • 2.0.0a3
    • 2.0.0a4
    • 2.0.0a5
    • 2.0.0a6
    • 2.0.0rc1
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.1.0
    • 3.0.0
    • 3.0.0a1
    • 3.0.0a2
    • 3.0.0a3
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.0rc5
    • 3.0.1
    • 3.0.2
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.2.0
    • 3.2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.0

    Auf 3.3.0 aktualisieren

  • mistune Ubuntu:16.04:LTS

    Softwareversionen
    • 0.6-2
    • 0.7.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:18.04:LTS

    Softwareversionen
    • 0.7.4-1
    • 0.8-1
    • 0.8.1-1
    • 0.8.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:20.04:LTS

    Softwareversionen
    • 0.8.4-1
    • 0.8.4-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:22.04:LTS

    Softwareversionen
    • 0.8.4-4
    • 0.8.4-5
    • 2.0.0-1+really0.8.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.4-2
    • 3.0.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:25.10

    Softwareversionen
    • 3.0.2-2
    • 3.1.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:26.10

    Softwareversionen
    • 3.1.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • mistune Ubuntu:26.04:LTS

    Softwareversionen
    • 3.1.3-1
    • 3.1.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →