CVE-2026-59938
CVE-2026-59938 · pypdf: Possible large memory usage for wrong image dimensions
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
pypdf is a free and open-source pure-python PDF library. Prior to 6.14.0, an attacker can craft a PDF with declared image size values that are much too large compared to the actual data, causing large memory usage in pypdf image parsing. This issue is fixed in version 6.14.0.
CVSS 6.9 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pypdf
- Softwareversionen
- < 6.14.0: Betroffen
Keine Korrektur veröffentlicht
pypdf Debian:12
- Softwareversionen
- 3.17.4-1
- 3.4.1-1
- 3.4.1-1+deb12u1
- 4.0.0-1
- 4.0.0-1~exp1
- 4.0.1-1
- 4.0.2-1
- 4.1.0-1
- 4.2.0-1
- 4.3.1-1
- 5.4.0-1
- 6.19.0-1
- 6.21.0-1
- 6.21.1-1
- 6.9.0-1
- 6.9.2-1
- 6.9.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Debian:13
- Softwareversionen
- 5.4.0-1
- 6.19.0-1
- 6.21.0-1
- 6.21.1-1
- 6.9.0-1
- 6.9.2-1
- 6.9.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Debian:14
- Softwareversionen
- 5.4.0-1
- 6.9.0-1
- 6.9.2-1
- 6.9.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.19.0-1
Auf 6.19.0-1 aktualisieren
pypdf2 Debian:12
- Softwareversionen
- 2.12.1-3
- 2.12.1-3+deb12u1
- 2.12.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf PyPI
- Softwareversionen
- 1.0
- 1.1
- 1.10
- 1.11
- 1.12
- 1.13
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7
- 1.8
- 1.9
- 3.1.0
- 3.10.0
- 3.11.0
- 3.11.1
- 3.12.0
- 3.12.1
- 3.12.2
- 3.13.0
- 3.14.0
- 3.15.0
- 3.15.1
- 3.15.2
- 3.15.3
- 3.15.4
- 3.15.5
- 3.16.0
- 3.16.1
- 3.16.2
- 3.16.3
- 3.16.4
- 3.17.0
- 3.17.1
- 3.17.2
- 3.17.3
- 3.17.4
- 3.2.0
- 3.2.1
- 3.3.0
- 3.4.0
- 3.4.1
- 3.5.0
- 3.5.1
- 3.5.2
- 3.6.0
- 3.7.0
- 3.7.1
- 3.8.0
- 3.8.1
- 3.9.0
- 3.9.1
- 4.0.0
- 4.0.1
- 4.0.2
- 4.1.0
- 4.2.0
- 4.3.0
- 4.3.1
- 5.0.0
- 5.0.1
- 5.1.0
- 5.2.0
- 5.3.0
- 5.3.1
- 5.4.0
- 5.5.0
- 5.6.0
- 5.6.1
- 5.7.0
- 5.8.0
- 5.9.0
- 6.0.0
- 6.1.0
- 6.1.1
- 6.1.2
- 6.1.3
- 6.10.0
- 6.10.1
- 6.10.2
- 6.11.0
- 6.12.0
- 6.12.1
- 6.12.2
- 6.13.0
- 6.13.1
- 6.13.2
- 6.13.3
- 6.2.0
- 6.3.0
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.6.0
- 6.6.1
- 6.6.2
- 6.7.0
- 6.7.1
- 6.7.2
- 6.7.3
- 6.7.4
- 6.7.5
- 6.8.0
- 6.9.0
- 6.9.1
- 6.9.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.14.0
Auf 6.14.0 aktualisieren
pypdf2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.23+git20141008-1
- 1.25.1-1
- 1.25.1-1ubuntu0.1~esm1
- 1.25.1-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf2 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.26.0-2
- 1.26.0-2ubuntu0.1~esm1
- 1.26.0-2ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf2 Ubuntu:20.04:LTS
- Softwareversionen
- 1.26.0-2
- 1.26.0-3ubuntu1
- 1.26.0-3ubuntu1.20.04.1
- 1.26.0-3ubuntu1.20.04.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf2 Ubuntu:22.04:LTS
- Softwareversionen
- 1.26.0-4
- 1.26.0-4ubuntu0.22.04.1
- 1.26.0-4ubuntu0.22.04.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Ubuntu:24.04:LTS
- Softwareversionen
- 3.4.1-1
- 3.17.4-1
- 4.0.0-1
- 4.0.1-1
- 4.0.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf2 Ubuntu:24.04:LTS
- Softwareversionen
- 2.12.1-3
- 2.12.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Ubuntu:25.10
- Softwareversionen
- 4.3.1-1
- 5.4.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Ubuntu:26.10
- Softwareversionen
- 6.9.2-1
- 6.9.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pypdf Ubuntu:26.04:LTS
- Softwareversionen
- 5.4.0-1
- 6.9.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht