p PatchFirst

CVE-2026-59973

CVE-2026-59973 · mcp-from-openapi: Bypass of OpenAPI external $ref SSRF fix in latest FrontMCP and mcp-from-openapi

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). From mcp-from-openapi 2.3.0 until 2.5.0 and from frontmcp and @frontmcp/adapters 1.2.1 until 1.5.0, libs/adapters/src/openapi/openapi.adapter.ts loadOpenAPISpec() forwards untrusted OpenAPI url and spec inputs and loadOptions.refResolution to OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON(). The external $ref guard checks parsed hostname strings without resolving addresses, pinning validated addresses, revalidating redirect targets, or normalizing IPv4-mapped IPv6. An authenticated user who can import or configure an OpenAPI specification in a hosted or multi-user deployment can use DNS-to-loopback resolution, redirect-to-loopback behavior, or IPv4-mapped IPv6 loopback forms to cause backend-origin requests to internal services. This can expose internal administrative APIs, metadata-like services, and other private network endpoints. The practical impact is lower when only a trusted local administrator can configure OpenAPI specs, and disabling external reference protocols prevents the external $ref request. This issue is fixed in mcp-from-openapi 2.5.0 and frontmcp and @frontmcp/adapters 1.5.0.

CVSS 8.5 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • frontmcp

    Softwareversionen
    • < 1.5.0: Betroffen

    Keine Korrektur veröffentlicht

  • mcp-from-openapi

    Softwareversionen
    • < 2.5.0: Betroffen

    Keine Korrektur veröffentlicht

  • adapters

    Softwareversionen
    • < 1.5.0: Betroffen

    Keine Korrektur veröffentlicht

  • mcp-from-openapi npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.3.0, < 2.5.0

    Auf 2.5.0 aktualisieren

  • @frontmcp/adapters npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.2.1, < 1.5.0

    Auf 1.5.0 aktualisieren

  • frontmcp npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.2.1, < 1.5.0

    Auf 1.5.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →