CVE-2026-61539
CVE-2026-61539 · Xinference: Remote code execution via unsafe `eval()` in Llama3 tool-call parsing
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Xinference is an inference API for running open-source, speech, and multimodal models. In 2.5.0 and earlier, Xinference passes attacker-influenced Llama3 tool-call output to eval() in xinference/model/llm/tool_parsers/llama3_tool_parser.py and xinference/model/llm/utils.py. Requests to /v1/chat/completions with a tools field flow through xinference/api/restful_api.py, xinference/model/llm/transformers/core.py, handle_chat_result_non_streaming(), and _post_process_completion() before extract_tool_calls() or _eval_llama3_chat_arguments() evaluates the model-generated Python expression. An unauthenticated remote attacker can influence that output through a crafted prompt and execute commands in the Xinference server process context. This issue is fixed in version 2.7.0.
CVSS 10.0 · Kritisch · EPSS 1,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
inference
- Softwareversionen
- < 2.7.0: Betroffen
Keine Korrektur veröffentlicht
xinference PyPI
- Softwareversionen
- 0.0.0
- 0.0.1
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.10.0
- 0.10.1
- 0.10.2
- 0.10.2.post1
- 0.10.3
- 0.11.0
- 0.11.1
- 0.11.2
- 0.11.2.post1
- 0.11.3
- 0.12.0
- 0.12.1
- 0.12.2
- 0.12.2.post1
- 0.12.3
- 0.13.0
- 0.13.1
- 0.13.2
- 0.13.3
- 0.13.4
- 0.14.0
- 0.14.0.post1
- 0.14.1
- 0.14.1.post1
- 0.14.2
- 0.14.3
- 0.14.4
- 0.14.4.post1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.16.0
- 0.16.1
- 0.16.2
- 0.16.3
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.3.0
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.4
- 0.5.5
- 0.5.6
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- 0.6.4
- 0.6.5
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.3.1
- 0.7.4
- 0.7.4.1
- 0.7.5
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.3.1
- 0.8.4
- 0.8.5
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.10.0
- 1.10.1
- 1.11.0
- 1.11.0.post1
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.17.1
- 1.2.0
- 1.2.1
- 1.2.2
- 1.3.0
- 1.3.0.post1
- 1.3.0.post2
- 1.3.1
- 1.3.1.post1
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.0.post1
- 1.5.0.post2
- 1.5.1
- 1.6.0
- 1.6.0.post1
- 1.6.1
- 1.7.0
- 1.7.0.post1
- 1.7.1
- 1.7.1.post1
- 1.8.0
- 1.8.1
- 1.8.1rc1
- 1.9.0
- 1.9.1
- 2.0.0
- 2.1.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0
Auf 2.7.0 aktualisieren
Originalquellen
- https://github.com/xorbitsai/inference/security/advisories/GHSA-x2rj-828p-hx9m
- https://github.com/xorbitsai/inference/pull/4786
- https://github.com/xorbitsai/inference/commit/1b3d220f342ce68d34cec4586d9409d457dadc42
- https://github.com/xorbitsai/inference/releases/tag/v2.7.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-61539