p PatchFirst

CVE-2026-61548

CVE-2026-61548 · Rsyslog: mmpstrucdata stack buffer overflow with oversized RFC5424 structured data

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Rsyslog is a rocket-fast system for log processing. From 7.5.4 until 8.2606.0, the optional mmpstrucdata plugin's parseSD_PARAM function in plugins/mmpstrucdata/mmpstrucdata.c stores RFC5424 parameter values in a fixed pVal[32 * 1024] stack buffer and calls parsePARAM_VALUE without supplying the destination size. A remote unauthenticated attacker whose crafted RFC5424 message reaches an action using mmpstrucdata can provide a structured-data parameter larger than that buffer when MaxMessageSize permits it, causing an attacker-controlled stack overwrite. Deployments that do not install and use the plugin, or whose effective message-size limit remains below the required threshold, are not affected by this issue. The demonstrated impact is a crash and interruption of log collection; code execution is not demonstrated. This issue is fixed in version 8.2606.0.

CVSS 8.1 · Hoch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • rsyslog

    Softwareversionen
    • >= 7.5.4, < 8.2606.0: Betroffen

    Keine Korrektur veröffentlicht

  • rsyslog Debian:12

    Softwareversionen
    • 8.2302.0-1
    • 8.2302.0-1+deb12u1
    • 8.2304.0-1
    • 8.2306.0-1
    • 8.2306.0-2
    • 8.2308.0-1
    • 8.2310.0-1
    • 8.2310.0-2
    • 8.2310.0-3
    • 8.2310.0-4
    • 8.2312.0-1
    • 8.2312.0-2
    • 8.2312.0-3
    • 8.2402.0-1
    • 8.2404.0-1
    • 8.2404.0-2
    • 8.2406.0-1
    • 8.2408.0-1
    • 8.2408.0-2
    • 8.2410.0-1
    • 8.2412.0-1
    • 8.2412.0-2
    • 8.2502.0-1
    • 8.2502.0-2
    • 8.2502.0-3
    • 8.2502.0-4
    • 8.2502.0-5
    • 8.2502.0-6
    • 8.2504.0-1
    • 8.2506.0-1
    • 8.2506.0-2
    • 8.2506.0-3
    • 8.2506.0-4
    • 8.2506.0-6
    • 8.2510.0-1
    • 8.2510.0-2
    • 8.2510.0-3
    • 8.2510.0-4
    • 8.2510.0-5
    • 8.2512.0-1
    • 8.2512.0-2
    • 8.2512.0-3
    • 8.2602.0-1
    • 8.2604.0-1
    • 8.2604.0-2
    • 8.2604.0-3
    • 8.2604.0-4
    • 8.2606.0-1
    • 8.2606.0-2
    • 8.2606.0-3
    • 8.2606.0-4
    • 8.2608.0-1
    • 8.2608.0-2
    • 8.2608.0-3
    • 8.2608.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rsyslog Debian:13

    Softwareversionen
    • 8.2504.0-1
    • 8.2504.0-1+deb13u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.2504.0-1+deb13u2

    Auf 8.2504.0-1+deb13u2 aktualisieren

  • rsyslog Debian:14

    Softwareversionen
    • 8.2504.0-1
    • 8.2506.0-1
    • 8.2506.0-2
    • 8.2506.0-3
    • 8.2506.0-4
    • 8.2506.0-6
    • 8.2510.0-1
    • 8.2510.0-2
    • 8.2510.0-3
    • 8.2510.0-4
    • 8.2510.0-5
    • 8.2512.0-1
    • 8.2512.0-2
    • 8.2512.0-3
    • 8.2602.0-1
    • 8.2604.0-1
    • 8.2604.0-2
    • 8.2604.0-3
    • 8.2604.0-4
    • 8.2606.0-1
    • 8.2606.0-2
    • 8.2606.0-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.2606.0-4

    Auf 8.2606.0-4 aktualisieren

  • rsyslog Ubuntu:14.04:LTS

    Softwareversionen
    • 5.8.11-2ubuntu4
    • 7.4.4-1ubuntu1
    • 7.4.4-1ubuntu2
    • 7.4.4-1ubuntu2.1
    • 7.4.4-1ubuntu2.3
    • 7.4.4-1ubuntu2.5
    • 7.4.4-1ubuntu2.6
    • 7.4.4-1ubuntu2.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rsyslog Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 8.12.0-1ubuntu2
    • 8.12.0-1ubuntu3
    • 8.14.0-2ubuntu1
    • 8.14.0-2ubuntu2
    • 8.16.0-1ubuntu1
    • 8.16.0-1ubuntu2
    • 8.16.0-1ubuntu3
    • 8.16.0-1ubuntu3.1
    • 8.16.0-1ubuntu3.1+esm1
    • 8.16.0-1ubuntu3.1+esm2
    • 8.16.0-1ubuntu3.1+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rsyslog Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 8.16.0-1ubuntu9
    • 8.16.0-1ubuntu10
    • 8.32.0-1ubuntu3
    • 8.32.0-1ubuntu4
    • 8.32.0-1ubuntu4.2
    • 8.32.0-1ubuntu4.2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rsyslog Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 8.1901.0-1ubuntu4
    • 8.2001.0-1ubuntu1
    • 8.2001.0-1ubuntu1.1
    • 8.2001.0-1ubuntu1.3
    • 8.2001.0-1ubuntu1.3+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rsyslog Ubuntu:22.04:LTS

    Softwareversionen
    • 8.2102.0-2ubuntu2
    • 8.2110.0-3ubuntu1
    • 8.2110.0-3ubuntu2
    • 8.2110.0-4ubuntu1
    • 8.2112.0-2ubuntu2
    • 8.2112.0-2ubuntu2.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.2112.0-2ubuntu2.4

    Auf 8.2112.0-2ubuntu2.4 aktualisieren

  • rsyslog Ubuntu:24.04:LTS

    Softwareversionen
    • 8.2306.0-2ubuntu2
    • 8.2312.0-3ubuntu1
    • 8.2312.0-3ubuntu2
    • 8.2312.0-3ubuntu3
    • 8.2312.0-3ubuntu7
    • 8.2312.0-3ubuntu8
    • 8.2312.0-3ubuntu9
    • 8.2312.0-3ubuntu9.1
    • 8.2312.0-3ubuntu9.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.2312.0-3ubuntu9.3

    Auf 8.2312.0-3ubuntu9.3 aktualisieren

  • rsyslog Ubuntu:26.04:LTS

    Softwareversionen
    • 8.2504.0-1ubuntu2
    • 8.2512.0-1ubuntu2
    • 8.2512.0-1ubuntu3
    • 8.2512.0-1ubuntu4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.2512.0-1ubuntu4.1

    Auf 8.2512.0-1ubuntu4.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →