p PatchFirst

CVE-2026-62322

CVE-2026-62322 · Python Social Auth: Login CSRF in LINE backend (LineOAuth2) — missing OAuth state validation (incomplete fix of 5.0.0 campaign)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Python Social Auth is a social authentication/registration mechanism. Prior to 5.0.2, the LINE backend exchanges an authorization code without validating the returned OAuth state. An attacker can begin authorization for an attacker-controlled LINE account and induce a victim to visit the resulting callback URL, causing the application to log the victim into the attacker's account. When account linking is enabled, the same missing validation can link the attacker's LINE identity to the victim's existing account and create a persistent unauthorized login path. Only applications with the LINE backend enabled are affected. This issue is fixed in version 5.0.2.

CVSS 6.5 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • social-core

    Softwareversionen
    • < 5.0.2: Betroffen

    Keine Korrektur veröffentlicht

  • social-auth-core Debian:12

    Softwareversionen
    • 4.3.0-1
    • 4.4.2-1
    • 4.4.2-2
    • 4.5.3-1
    • 4.5.4-1
    • 4.5.6-1
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • social-auth-core Debian:13

    Softwareversionen
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • social-auth-core Debian:14

    Softwareversionen
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.0.2-1

    Auf 5.0.2-1 aktualisieren

  • social-auth-core PyPI

    Softwareversionen
    • 0.0.1
    • 0.1.0
    • 0.2.0
    • 0.2.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 2.0.0
    • 3.0.0
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.4.0
    • 4.0.2
    • 4.0.3
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.4.0
    • 4.4.1
    • 4.4.2
    • 4.5.0
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.6.0
    • 4.6.1
    • 4.7.0
    • 4.8.0
    • 4.8.1
    • 4.8.2
    • 4.8.3
    • 4.8.4
    • 4.8.5
    • 4.8.6
    • 4.8.7
    • 4.9.0
    • 4.9.1
    • 5.0.0
    • 5.0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.0.2

    Auf 5.0.2 aktualisieren

  • social-auth-core Ubuntu:20.04:LTS

    Softwareversionen
    • 3.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • social-auth-core Ubuntu:22.04:LTS

    Softwareversionen
    • 3.1.0-1.1
    • 4.1.0-1
    • 4.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • social-auth-core Ubuntu:24.04:LTS

    Softwareversionen
    • 4.4.2-2
    • 4.5.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • social-auth-core Ubuntu:26.04:LTS

    Softwareversionen
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →