p PatchFirst

CVE-2026-63632

CVE-2026-63632 · ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. From 1.3.0 until 1.22.0, onnx.version_converter.convert_version() can perform an out-of-bounds read in Gemm_7_6::adapt_gemm_7_6() in onnx/version_converter/adapters/gemm_7_6.h when a Gemm node has input tensors with fewer than two dimensions because B_shape[1], A_shape[0], or A_shape[1] is accessed without a rank check, potentially causing a process crash during an opset 7 to 6 downgrade. This issue is fixed in version 1.22.0.

CVSS 3.3 · Niedrig · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • onnx

    Softwareversionen
    • >= 1.3.0, < 1.22.0: Betroffen

    Keine Korrektur veröffentlicht

  • onnx Debian:12

    Softwareversionen
    • 1.12.0-2
    • 1.13.1-1
    • 1.13.1-2
    • 1.13.1-3
    • 1.14.1-1
    • 1.14.1-2
    • 1.14.1-2.1
    • 1.14.1-2.1~exp1
    • 1.16.1-1
    • 1.16.2-1
    • 1.17.0-1
    • 1.17.0-2
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Debian:13

    Softwareversionen
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Debian:14

    Softwareversionen
    • 1.17.0-3
    • 1.19.1-1~exp1
    • 1.20.0-1
    • 1.20.0-1~exp1
    • 1.20.0-3
    • 1.20.0-4
    • 1.20.0-5
    • 1.20.0-6
    • 1.21.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx PyPI

    Softwareversionen
    • 1.10.0
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.13.1
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.16.0
    • 1.16.1
    • 1.16.2
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.19.1
    • 1.19.1rc1
    • 1.20.0
    • 1.20.0rc1
    • 1.20.0rc2
    • 1.20.1
    • 1.20.1rc1
    • 1.21.0
    • 1.21.0rc1
    • 1.21.0rc2
    • 1.21.0rc3
    • 1.21.0rc4
    • 1.22.0rc1
    • 1.22.0rc2
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 1.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.3.0, < 1.22.0

    Auf 1.22.0 aktualisieren

  • onnx Ubuntu:22.04:LTS

    Softwareversionen
    • 1.7.0+dfsg-3build1
    • 1.7.0+dfsg-3build2
    • 1.7.0+dfsg-3ubuntu1
    • 1.7.0+dfsg-3ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.13.1-3
    • 1.13.1-3build1
    • 1.14.1-2
    • 1.14.1-2.1
    • 1.14.1-2.1build1
    • 1.14.1-2.1build2
    • 1.14.1-2.1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:26.10

    Softwareversionen
    • 1.20.0-1
    • 1.20.0-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • onnx Ubuntu:26.04:LTS

    Softwareversionen
    • 1.17.0-3build1
    • 1.20.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →