p PatchFirst

CVE-2026-65979

CVE-2026-65979 · OpenEXR: Out-of-bounds read in HTJ2K decoder from unvalidated chunk header length (PLEN)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. From version 3.4.0 through 3.4.12, the HTJ2K decoder parses a header-length field (PLEN) from a chunk's compressed data but never checks that this value fits within the available buffer before using it. When decoding, it advances the codestream pointer by the attacker-supplied header size and passes the resulting offset and remaining length to the OpenJPH memory-input path, so a crafted value pushes the pointer past the end of the buffer and causes an out-of-bounds read. Because this field comes straight from attacker-controlled EXR chunk data, the flaw is reachable during normal decoding of an untrusted file. This issue is fixed in version 3.4.13.

CVSS 6.7 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • openexr

    Softwareversionen
    • >= 3.4.0, < 3.4.13: Betroffen

    Keine Korrektur veröffentlicht

  • openexr Debian:14

    Softwareversionen
    • 3.1.13-2
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.14-0.1

    Auf 3.4.14-0.1 aktualisieren

  • openexr Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.2.0-1ubuntu3
    • 2.2.0-7ubuntu1
    • 2.2.0-9ubuntu1
    • 2.2.0-10ubuntu2
    • 2.2.0-10ubuntu2.1
    • 2.2.0-10ubuntu2.2
    • 2.2.0-10ubuntu2.3
    • 2.2.0-10ubuntu2.4
    • 2.2.0-10ubuntu2.6
    • 2.2.0-10ubuntu2.6+esm1
    • 2.2.0-10ubuntu2.6+esm2
    • 2.2.0-10ubuntu2.6+esm3
    • 2.2.0-10ubuntu2.6+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2.2.0-11ubuntu1
    • 2.2.0-11.1ubuntu1
    • 2.2.0-11.1ubuntu1.1
    • 2.2.0-11.1ubuntu1.2
    • 2.2.0-11.1ubuntu1.3
    • 2.2.0-11.1ubuntu1.4
    • 2.2.0-11.1ubuntu1.6
    • 2.2.0-11.1ubuntu1.7
    • 2.2.0-11.1ubuntu1.8
    • 2.2.0-11.1ubuntu1.9
    • 2.2.0-11.1ubuntu1.9+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2.2.1-4.1ubuntu1
    • 2.3.0-6
    • 2.3.0-6build1
    • 2.3.0-6ubuntu0.1
    • 2.3.0-6ubuntu0.2
    • 2.3.0-6ubuntu0.3
    • 2.3.0-6ubuntu0.5
    • 2.3.0-6ubuntu0.5+esm1
    • 2.3.0-6ubuntu0.5+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 2.5.4-2
    • 2.5.7-1
    • 2.5.7-1ubuntu0.1~esm1
    • 2.5.7-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 3.1.5-5.1
    • 3.1.5-5.1build1
    • 3.1.5-5.1build2
    • 3.1.5-5.1build3
    • 3.1.5-5.1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:26.10

    Softwareversionen
    • 3.1.13-2build1
    • 3.4.6+ds-4ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 3.1.13-2
    • 3.1.13-2build1
    • 3.1.13-2ubuntu0.26.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →