CVE-2026-68514
CVE-2026-68514 · OpenEXR: Heap buffer overflow in PyOpenEXR from literal/prefixed RGB channel name collision in deep images
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenEXR is the reference implementation and specification for the EXR image file format, widely used in the motion picture industry. In versions 3.3.0 through 3.3.12 and 3.4.0 through 3.4.13, the PyOpenEXR Python bindings contain a heap out-of-bounds write triggered when reading a crafted deep scanline EXR file. When a deep file declares a literal channel named left alongside layer-prefixed RGB channels left.R, left.G, and left.B, the wrapper processes the literal left channel first and allocates a scalar deep sample array for it, then reuses that same array as the coalesced destination for the prefixed RGB group. The deep reader registers sample slices with an RGB stride (three lanes) into storage that was allocated with scalar shape, so decoding the deep samples writes past the allocation. Opening such a file through the default public Python API, OpenEXR.File(path), causes a heap buffer overflow during normal deep sample decode, leading to memory corruption and a crash. This issue is fixed in versions 3.3.13 and 3.4.14.
CVSS 5.5 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
openexr
- Softwareversionen
- >= 3.3.0, < 3.3.13: Betroffen
- >= 3.4.0, < 3.4.14: Betroffen
Keine Korrektur veröffentlicht
openexr Debian:14
- Softwareversionen
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.14-0.1
Auf 3.4.14-0.1 aktualisieren
openexr Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- 2.2.0-10ubuntu2.6+esm1
- 2.2.0-10ubuntu2.6+esm2
- 2.2.0-10ubuntu2.6+esm3
- 2.2.0-10ubuntu2.6+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- 2.2.0-11.1ubuntu1.7
- 2.2.0-11.1ubuntu1.8
- 2.2.0-11.1ubuntu1.9
- 2.2.0-11.1ubuntu1.9+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- 2.3.0-6ubuntu0.5+esm1
- 2.3.0-6ubuntu0.5+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2.5.4-2
- 2.5.7-1
- 2.5.7-1ubuntu0.1~esm1
- 2.5.7-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- 3.1.5-5.1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:26.10
- Softwareversionen
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 3.1.13-2
- 3.1.13-2build1
- 3.1.13-2ubuntu0.26.04.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-mw28-66qc-c883
- https://github.com/AcademySoftwareFoundation/openexr/commit/c1f3ec0d91cfa5a8035ecd00920835ac76e01640
- https://github.com/AcademySoftwareFoundation/openexr/commit/d134e3cd81a2e343f2919e86bf949f576b1ab16a
- https://nvd.nist.gov/vuln/detail/CVE-2026-68514