CVE-2026-71438
CVE-2026-71438 · Mermaid configuration APIs allow prototype pollution
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.
CVSS 2.4 · Niedrig · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
mermaid
- Softwareversionen
- < 10.9.8: Betroffen
- >= 11.0.0-alpha.1, < 11.16.1: Betroffen
Keine Korrektur veröffentlicht
node-mermaid Debian:14
- Softwareversionen
- 8.11.0+ds+~cs29.13.22-1
- 8.13.2+ds+~cs30.13.21-1
- 8.13.2+ds+~cs30.13.21-1.1
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- 8.14.0+ds1+~cs11.4.14-1
- 8.14.0+~cs11.4.14-1
- 8.7.0+ds+~cs27.17.17-1
- 8.7.0+ds+~cs27.17.17-2
- 8.7.0+ds+~cs27.17.17-2~bpo10+1
- 8.7.0+ds+~cs27.17.17-3
- 8.9.1+ds+~cs26.20.25-1
- 8.9.3+ds+~cs29.13.19-1
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mermaid npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 11.0.0-alpha.1, < 11.16.1
Auf 11.16.1 aktualisieren
mermaid npm
- Betroffene Versionsbereiche
- SEMVER: < 10.9.8
Auf 10.9.8 aktualisieren
node-mermaid Ubuntu:22.04:LTS
- Softwareversionen
- 8.7.0+ds+~cs27.17.17-3
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-mermaid Ubuntu:26.10
- Softwareversionen
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/mermaid-js/mermaid/security/advisories/GHSA-c4c3-pg64-4m4v
- https://github.com/mermaid-js/mermaid/pull/8022
- https://github.com/mermaid-js/mermaid/commit/2cd6dcf735533b323507e3e889ffdea870540b43
- https://github.com/mermaid-js/mermaid/commit/c34b07a0815842327e70794d69b0c8c5a1e2a956
- https://github.com/mermaid-js/mermaid/releases/tag/mermaid%4011.16.1
- https://github.com/mermaid-js/mermaid/releases/tag/v10.9.8
- https://nvd.nist.gov/vuln/detail/CVE-2026-71438