p PatchFirst

CVE-2026-71851

CVE-2026-71851 · crypto-js: Insufficient Entropy in Cryptographic Secret Generation via Vulnerable CryptoJS Dependency Chain

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

crypto-js is a JavaScript library of crypto standards. Versions of crypto-js prior to 4.0.0 generate randomness in CryptoJS.lib.WordArray.random() using a custom variation of the Multiply-With-Carry pseudorandom number generator, seeded from Math.random(), instead of a cryptographically secure source. This generator was introduced in version 3.1.2-4 and remained present in nearly every 3.x release. Nominal requests for 128 or 256 bits of entropy through this function produce effective search spaces of approximately 2 to the 39th and 2 to the 47th possibilities, small enough to enumerate on commodity hardware. Downstream wallet applications that used CryptoJS.lib.WordArray.random() as the entropy source for BIP39 recovery phrases are affected, and an attacker who enumerates the reduced output space can recover the resulting private keys and control the associated funds. This issue is fixed in version 4.0.0.

CVSS 9.0 · Kritisch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • crypto-js

    Softwareversionen
    • < 4.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • cryptojs Debian:12

    Softwareversionen
    • 3.1.2+dfsg-3
    • 3.1.2+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • crypto-js npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.0.0

    Auf 4.0.0 aktualisieren

  • cryptojs Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 3.1.2+dfsg-1
    • 3.1.2+dfsg-2
    • 3.1.2+dfsg-2ubuntu0.16.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cryptojs Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.1.2+dfsg-2
    • 3.1.2+dfsg-2ubuntu0.18.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cryptojs Ubuntu:20.04:LTS

    Softwareversionen
    • 3.1.2+dfsg-2
    • 3.1.2+dfsg-2ubuntu0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cryptojs Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 3.1.2+dfsg-3
    • 3.1.2+dfsg-3ubuntu0.22.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cryptojs Ubuntu:24.04:LTS

    Softwareversionen
    • 3.1.2+dfsg-3
    • 3.1.2+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →