p PatchFirst

CVE-2026-73086

CVE-2026-73086 · nanoid: Integer Overflow or Wraparound

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

nanoid is a secure, URL-friendly, unique string ID generator for JavaScript. Prior to versions 3.3.12 and 5.1.11, the nanoid(size) function in index.js and index.cjs coerces the user-influenced size parameter to a signed 32-bit integer, allowing a value of 2147483648 to become -2147483648 and corrupt the process-wide CSPRNG poolOffset in fillPool(), which causes subsequent session tokens, CSRF tokens, API keys, and unique identifiers to become the deterministic string "uuuuuuuuuuuuuuuuuuuuu" until the process restarts. This issue is fixed in versions 3.3.12 and 5.1.11.

CVSS 7.4 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • nanoid

    Softwareversionen
    • < 3.3.12: Betroffen
    • >= 4.0.0, < 5.1.11: Betroffen

    Keine Korrektur veröffentlicht

  • node-mocha Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.4+ds1+~cs28.2.8-1

    Auf 9.1.4+ds1+~cs28.2.8-1 aktualisieren

  • node-mocha Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.4+ds1+~cs28.2.8-1

    Auf 9.1.4+ds1+~cs28.2.8-1 aktualisieren

  • node-mocha Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.4+ds1+~cs28.2.8-1

    Auf 9.1.4+ds1+~cs28.2.8-1 aktualisieren

  • node-postcss Debian:12

    Softwareversionen
    • 8.4.20+~cs8.0.23-1
    • 8.4.20+~cs8.0.23-1+deb12u1
    • 8.4.31+~cs8.0.26-1
    • 8.4.39+~cs9.2.29-1
    • 8.4.49+~cs9.2.32-1
    • 8.5.12+~cs9.3.32-1
    • 8.5.14+~cs9.3.34-1
    • 8.5.15+~cs9.3.34-1
    • 8.5.15+~cs9.3.38-1
    • 8.5.15+~cs9.3.39-1
    • 8.5.19+~cs10.2.23-1
    • 8.5.21+~cs10.2.23-1
    • 8.5.23+~cs10.2.23-1
    • 8.5.25+~cs10.2.23-1
    • 8.5.26+~cs10.2.24-1
    • 8.5.28+~cs10.2.24-1
    • 8.5.31+~cs10.2.26-1
    • 8.5.6+~cs9.3.28-1
    • 8.5.8+~cs9.3.30-1
    • 8.5.9+~cs9.3.30-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Debian:13

    Softwareversionen
    • 8.4.49+~cs9.2.32-1
    • 8.5.12+~cs9.3.32-1
    • 8.5.14+~cs9.3.34-1
    • 8.5.15+~cs9.3.34-1
    • 8.5.15+~cs9.3.38-1
    • 8.5.15+~cs9.3.39-1
    • 8.5.19+~cs10.2.23-1
    • 8.5.21+~cs10.2.23-1
    • 8.5.23+~cs10.2.23-1
    • 8.5.25+~cs10.2.23-1
    • 8.5.26+~cs10.2.24-1
    • 8.5.28+~cs10.2.24-1
    • 8.5.31+~cs10.2.26-1
    • 8.5.6+~cs9.3.28-1
    • 8.5.8+~cs9.3.30-1
    • 8.5.9+~cs9.3.30-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Debian:14

    Softwareversionen
    • 8.4.49+~cs9.2.32-1
    • 8.5.12+~cs9.3.32-1
    • 8.5.6+~cs9.3.28-1
    • 8.5.8+~cs9.3.30-1
    • 8.5.9+~cs9.3.30-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.5.14+~cs9.3.34-1

    Auf 8.5.14+~cs9.3.34-1 aktualisieren

  • nanoid npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.3.12

    Auf 3.3.12 aktualisieren

  • nanoid npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 5.1.11

    Auf 5.1.11 aktualisieren

  • node-mocha Ubuntu:16.04:LTS

    Softwareversionen
    • 1.20.1-1
    • 1.20.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-mocha Ubuntu:18.04:LTS

    Softwareversionen
    • 1.20.1-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-mocha Ubuntu:20.04:LTS

    Softwareversionen
    • 4.1.0+ds3-5
    • 7.0.1+ds1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Ubuntu:20.04:LTS

    Softwareversionen
    • 6.0.23-1
    • 6.0.23-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Ubuntu:22.04:LTS

    Softwareversionen
    • 8.2.1+~cs5.3.23-8
    • 8.4.5+~cs7.1.51-2
    • 8.4.6+~cs7.3.21-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Ubuntu:24.04:LTS

    Softwareversionen
    • 8.4.20+~cs8.0.23-1
    • 8.4.31+~cs8.0.26-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-postcss Ubuntu:26.04:LTS

    Softwareversionen
    • 8.5.6+~cs9.3.28-1
    • 8.5.8+~cs9.3.30-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →