p PatchFirst

CVE-2026-73419

CVE-2026-73419 · NextAuth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

NextAuth.js provides authentication for Next.js. Prior to@auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, Auth.js stores the OAuth/OIDC anti-CSRF checks state, nonce, and the PKCE verifier in global cookies that are not bound to the provider that created them. On callback, a check value minted during a sign-in started with one provider can satisfy the callback for a different provider because the stored cookie is not verified against the callback provider's identity, including the provider ID, issuer, client ID, or redirect URI. In a multi-provider application that permits account linking while logged in, when one provider's authorization request is observable and a target provider callback can be satisfied without a PKCE verifier, an attacker can lure a victim into starting a legitimate same-origin flow and link the attacker's target-provider account to the victim's Auth.js user. The linked provider grants the attacker persistent sign-in to the victim's account, while cross-site request forgery alone is insufficient. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

CVSS 6.8 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next-auth

    Softwareversionen
    • < 4.24.15: Betroffen
    • >= 5.0.0-beta.4, < 5.0.0-beta.32: Betroffen

    Keine Korrektur veröffentlicht

  • core

    Softwareversionen
    • < 0.41.3: Betroffen

    Keine Korrektur veröffentlicht

  • @auth/core npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.41.3

    Auf 0.41.3 aktualisieren

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.0.0-beta.1, < 5.0.0-beta.32

    Auf 5.0.0-beta.32 aktualisieren

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.24.15

    Auf 4.24.15 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →