CVE-2026-74870
CVE-2026-74870 · openssl_encrypt before 1.4.8 Hardware Pepper Information Disclosure
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
openssl_encrypt (pip) versions <= 1.4.7 contain an information exposure vulnerability where the 'hsm fido2-test' and 'hsm onlykey-test' diagnostic commands unconditionally print the full derived hardware pepper as hex to stdout/stderr (crypt_cli.py, handle_hsm_command). The printed value can persist in terminal scrollback, session recordings, or CI logs. Impact is limited because the pepper is derived from a random per-invocation test salt and is salt-bound, so the leaked value cannot be used to decrypt real files. A related plugin issue logged raw prf_data outside the secret-redaction path. Fixed in 1.4.8 (and 1.5.0) by removing the hex dumps and routing plugin debug output through the redaction layer.
CVSS 8.7 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
openssl_encrypt
- Softwareversionen
- ≥ 0, < 1.4.8: Betroffen (semver)
- 1.4.8: Nicht betroffen (semver)
Auf 1.4.8 aktualisieren
openssl-encrypt PyPI
- Softwareversionen
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.5.1
- 0.5.3
- 0.6.0rc1
- 0.7.0rc2
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.4.0
- 1.4.0b3
- 1.4.0b4
- 1.4.0b5
- 1.4.0b6
- 1.4.0b7
- 1.4.0b8
- 1.4.1
- 1.4.1rc2
- 1.4.2
- 1.4.4
- 1.4.5
- 1.4.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.7
Auf 1.4.7 aktualisieren