CVE-2026-74887
CVE-2026-74887 · openssl_encrypt before 1.4.0 Insecure Random Import in PQC Module
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
openssl_encrypt before 1.4.0 imports Python's non-cryptographic 'random' module (Mersenne Twister PRNG) at line 15 of openssl_encrypt/modules/pqc.py. No direct calls to random.* were present in the code, so no cryptographic operation is currently affected; however, the import creates a hazard that future code could inadvertently use random.randint() instead of a cryptographically secure alternative (secrets/os.urandom), producing predictable values since the Mersenne Twister state can be recovered from approximately 624 outputs. Fixed by removing the import in 1.4.0.
CVSS 6.3 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
openssl_encrypt
- Softwareversionen
- ≥ 0, < 1.4.0: Betroffen (semver)
- 1.4.0: Nicht betroffen (semver)
Auf 1.4.0 aktualisieren
openssl-encrypt PyPI
- Softwareversionen
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.5.1
- 0.5.3
- 0.6.0rc1
- 0.7.0rc2
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.4.0b3
- 1.4.0b4
- 1.4.0b5
- 1.4.0b6
- 1.4.0b7
- 1.4.0b8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.0
Auf 1.4.0 aktualisieren