CVE-2026-78132
CVE-2026-78132
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
strongSwan 5.1.3 through 6.0.7 has an infinite loop in the x509 plugin's attribute certificate parser for ietfAttrSyntax.
CVSS 7.5 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
strongswan
- Softwareversionen
- ≥ 5.1.3, < 6.1.0: Betroffen (semver)
Auf 6.1.0 aktualisieren
strongswan Debian:12
- Softwareversionen
- 5.9.11-1
- 5.9.11-2
- 5.9.12-1
- 5.9.13-1
- 5.9.13-2
- 5.9.8-5
- 5.9.8-5+deb12u1
- 5.9.8-5+deb12u2
- 5.9.8-5+deb12u3
- 5.9.8-5+deb12u4
- 5.9.8-5+deb12u5
- 6.0.0-1
- 6.0.0-2
- 6.0.1-1
- 6.0.1-2
- 6.0.1-3
- 6.0.1-4
- 6.0.1-5
- 6.0.1-6
- 6.0.2-1
- 6.0.3-1
- 6.0.4-1
- 6.0.5-1
- 6.0.6-1
- 6.0.7-1
- 6.1.0-1
- 6.1.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Debian:13
- Softwareversionen
- 6.0.1-6
- 6.0.1-6+deb13u1
- 6.0.1-6+deb13u2
- 6.0.1-6+deb13u4
- 6.0.1-6+deb13u5
- 6.0.1-6+deb13u6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.1-6+deb13u7
Auf 6.0.1-6+deb13u7 aktualisieren
strongswan Debian:14
- Softwareversionen
- 6.0.1-6
- 6.0.2-1
- 6.0.3-1
- 6.0.4-1
- 6.0.5-1
- 6.0.6-1
- 6.0.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.1.0-1
Auf 6.1.0-1 aktualisieren
strongswan Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- 5.1.2-0ubuntu2.11+esm1
- 5.1.2-0ubuntu2.11+esm2
- 5.1.2-0ubuntu2.11+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- 5.3.5-1ubuntu3.8+esm2
- 5.3.5-1ubuntu3.8+esm3
- 5.3.5-1ubuntu3.8+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Softwareversionen
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- 5.3.5-1ubuntu3.fips.3.8.2
- 5.3.5-1ubuntu3.fips.3.8.3
- 5.3.5-1ubuntu3.fips.3.8.6
- 5.3.5-1ubuntu3.fips.3.8.7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Softwareversionen
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- 5.6.2-1ubuntu2.8
- 5.6.2-1ubuntu2.9
- 5.6.2-1ubuntu2.9+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Softwareversionen
- 5.6.2-1ubuntu2.fips.2.5.1
- 5.6.2-1ubuntu2.fips.2.7.1
- 5.6.2-1ubuntu2.fips.2.7.2
- 5.6.2-1ubuntu2.fips.2.8.1
- 5.6.2-1ubuntu2.fips.2.9
- 5.6.2-1ubuntu2.fips.2.9+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Softwareversionen
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:20.04:LTS
- Softwareversionen
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- 5.8.2-1ubuntu3.4
- 5.8.2-1ubuntu3.5
- 5.8.2-1ubuntu3.6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Softwareversionen
- 5.8.2-1ubuntu3.fips.3.1.2
- 5.8.2-1ubuntu3.fips.3.3.1
- 5.8.2-1ubuntu3.fips.3.4.1
- 5.8.2-1ubuntu3.fips.3.5
- 5.8.2-1ubuntu3.fips.3.6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Softwareversionen
- 5.8.2-1ubuntu3.fips.3.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:22.04:LTS
- Softwareversionen
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- 5.9.4-1ubuntu4
- 5.9.5-2ubuntu1
- 5.9.5-2ubuntu2
- 5.9.5-2ubuntu2.1
- 5.9.5-2ubuntu2.2
- 5.9.5-2ubuntu2.3
- 5.9.5-2ubuntu2.4
- 5.9.5-2ubuntu2.5
- 5.9.5-2ubuntu2.6
- 5.9.5-2ubuntu2.7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.5-2ubuntu2.8
Auf 5.9.5-2ubuntu2.8 aktualisieren
strongswan Ubuntu:Pro:FIPS-preview:22.04:LTS
- Softwareversionen
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:Pro:FIPS-updates:22.04:LTS
- Softwareversionen
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- 5.9.5-2ubuntu2.3+Fips1
- 5.9.5-2ubuntu2.4+Fips1
- 5.9.5-2ubuntu2.5+Fips1
- 5.9.5-2ubuntu2.6+Fips1
- 5.9.5-2ubuntu2.7+Fips1
- 5.9.5-2ubuntu2.8+Fips1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:24.04:LTS
- Softwareversionen
- 5.9.11-1ubuntu1
- 5.9.11-1ubuntu2
- 5.9.12-1ubuntu1
- 5.9.13-2ubuntu1
- 5.9.13-2ubuntu3
- 5.9.13-2ubuntu4
- 5.9.13-2ubuntu4.24.04.1
- 5.9.13-2ubuntu4.24.04.2
- 5.9.13-2ubuntu4.24.04.3
- 5.9.13-2ubuntu4.24.04.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.13-2ubuntu4.24.04.5
Auf 5.9.13-2ubuntu4.24.04.5 aktualisieren
strongswan Ubuntu:26.04:LTS
- Softwareversionen
- 6.0.1-6ubuntu4
- 6.0.1-6ubuntu5
- 6.0.4-1ubuntu1
- 6.0.4-1ubuntu2
- 6.0.4-1ubuntu3
- 6.0.4-1ubuntu3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.4-1ubuntu3.2
Auf 6.0.4-1ubuntu3.2 aktualisieren