p PatchFirst

CVE-2026-81883

CVE-2026-81883 · radare2: Out-of-bounds Read at the end of string in the LUA 5.3 bytecode

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

radare2 is a UNIX-like reverse engineering framework and command-line toolset. Prior to 6.2.0, radare2's Lua 5.3 bytecode function parser was vulnerable because the Lua 5.3 bytecode function parser read fixed function-metadata fields immediately after a function-name string without checking the remaining buffer length. The vulnerability is triggered by opening or inspecting a crafted Lua 5.3 bytecode file whose function-name string ends at the input-buffer boundary. The parser read two integers and three one-byte fields beyond the allocated input buffer. This can cause invalid parser results or process termination; no attacker-observable memory disclosure has been demonstrated. This issue is fixed in version 6.2.0.

CVSS 3.3 · Niedrig · EPSS 0,2%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • radare2

    Softwareversionen
    • < 6.2.0: Betroffen

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:16.04:LTS

    Softwareversionen
    • 0.9.6-3.1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.6.0+dfsg-1
    • 2.0.0+dfsg-1
    • 2.1.0+dfsg-1
    • 2.3.0+dfsg-1
    • 2.3.0+dfsg-2
    • 2.3.0+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.2.1+dfsg-5build1
    • 4.0.0+dfsg-1
    • 4.2.1+dfsg-1
    • 4.2.1+dfsg-2
    • 4.2.1+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 5.5.0+dfsg-1ubuntu1
    • 5.5.0+dfsg-1.1ubuntu2
    • 5.5.0+dfsg-1.1ubuntu3
    • 5.5.0+dfsg-1.1ubuntu3+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:26.10

    Softwareversionen
    • 6.0.7+ds-1
    • 6.1.6+ds-2
    • 6.1.6+ds-3
    • 6.1.8+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • radare2 Ubuntu:26.04:LTS

    Softwareversionen
    • 5.9.8+dfsg-2
    • 6.0.4+dfsg-1
    • 6.0.7+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →