CVE-2026-83607
CVE-2026-83607 · xmldom: Element name injection via createElement() bypasses requireWellFormed
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Document.createElement(tagName) stores an unvalidated element name and XMLSerializer.serializeToString() emits that name verbatim. The requireWellFormed: true path did not validate the element qualified name or synthesized xmlns:PREFIX declaration, so attacker-controlled tag names could inject attributes, elements, or processing instructions into serialized XML or HTML and could cause cross-site scripting when browser-consumed. The unchecked values violate the XML QName constraint, and default serialization and creation-time createElement() behavior remain permissive. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.
CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
xmldom
- Softwareversionen
- <= 0.6.0: Betroffen
Keine Korrektur veröffentlicht
xmldom
- Softwareversionen
- >= 0.7.0, < 0.8.14: Betroffen
- >= 0.9.0, < 0.9.11: Betroffen
Keine Korrektur veröffentlicht
node-xmldom Debian:12
- Softwareversionen
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-xmldom Debian:13
- Softwareversionen
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-xmldom Debian:14
- Softwareversionen
- 0.9.10-1
- 0.9.10-2
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.9.11-1
Auf 0.9.11-1 aktualisieren
@xmldom/xmldom npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.9.0, < 0.9.11
Auf 0.9.11 aktualisieren
@xmldom/xmldom npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.7.0, < 0.8.14
Auf 0.8.14 aktualisieren
xmldom npm
- Betroffene Versionsbereiche
- SEMVER: ≤ 0.6.0
Keine Korrektur veröffentlicht
node-xmldom Ubuntu:20.04:LTS
- Softwareversionen
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-xmldom Ubuntu:22.04:LTS
- Softwareversionen
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-xmldom Ubuntu:24.04:LTS
- Softwareversionen
- 0.8.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-xmldom Ubuntu:26.04:LTS
- Softwareversionen
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/xmldom/xmldom/security/advisories/GHSA-w2rr-34g9-rvrj
- https://github.com/xmldom/xmldom/pull/1043
- https://github.com/xmldom/xmldom/pull/1050
- https://github.com/xmldom/xmldom/commit/cba1321218b069182695813fa7565653708e172e
- https://github.com/xmldom/xmldom/commit/d8212e632507eaf1d9f609657dd4c56abeb12d44
- https://github.com/xmldom/xmldom/releases/tag/0.8.14
- https://github.com/xmldom/xmldom/releases/tag/0.9.11
- https://nvd.nist.gov/vuln/detail/CVE-2026-83607