p PatchFirst

CVE-2026-83612

CVE-2026-83612 · xmldom: HTML raw-text closing-tag case mismatch causes output amplification

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. From 0.9.0-beta.1 until 0.9.12, HTML-mode parsing through DOMParser.parseFromString() mishandles a mixed-case closing tag for the script, style, textarea, or title raw-text elements. parseHtmlSpecialContent, selected by isHTMLRawTextElement or isHTMLEscapableRawTextElement, uses a case-sensitive indexOf() and then calls substring() with a missing-close result of negative one, causing unstable parser progression and quadratic output amplification. A small untrusted text/html document can consequently consume disproportionate CPU and memory when parsed and serialized. This issue is fixed in @xmldom/xmldom version 0.9.12.

CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • xmldom

    Softwareversionen
    • >= 0.9.0-beta.1, < 0.9.12: Betroffen

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:12

    Softwareversionen
    • 0.8.6-1
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.5-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:13

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:14

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.9.12-1

    Auf 0.9.12-1 aktualisieren

  • @xmldom/xmldom npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.0-beta.1, < 0.9.12

    Auf 0.9.12 aktualisieren

  • node-xmldom Ubuntu:20.04:LTS

    Softwareversionen
    • 0.1.27+ds-1
    • 0.1.27+ds-1+deb10u2build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:22.04:LTS

    Softwareversionen
    • 0.5.0-1
    • 0.7.3-1
    • 0.7.5-1
    • 0.7.5-1ubuntu0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:24.04:LTS

    Softwareversionen
    • 0.8.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.10

    Softwareversionen
    • 0.9.8-2
    • 0.9.10-2
    • 0.9.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.04:LTS

    Softwareversionen
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →