p PatchFirst

CVE-2026-83617

CVE-2026-83617 · xmldom: requireWellFormed element/attribute name validation is bypassable via an embedded line terminator

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. From 0.9.11 until 0.9.12, the requireWellFormed: true element and attribute name checks use the anchored QName_exact expression produced by reg() in lib/grammar.js, which inherits the multiline flag. A name with a valid first line followed by U+000A, U+000D, U+2028, or U+2029 and breakout markup therefore passes validation and is emitted verbatim in element start and end tags or attribute names. This bypasses the strict-serialization checks introduced for the earlier element-name and attribute-name injection advisories, while the default serialization path remains outside the strict guarantee. This issue is fixed in @xmldom/xmldom version 0.9.12.

CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • xmldom

    Softwareversionen
    • >= 0.9.11, < 0.9.12: Betroffen

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:12

    Softwareversionen
    • 0.8.6-1
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.5-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:13

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:14

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.9.12-1

    Auf 0.9.12-1 aktualisieren

  • @xmldom/xmldom npm

    Softwareversionen
    • 0.9.11
    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.11, < 0.9.12

    Auf 0.9.12 aktualisieren

  • node-xmldom Ubuntu:20.04:LTS

    Softwareversionen
    • 0.1.27+ds-1
    • 0.1.27+ds-1+deb10u2build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:22.04:LTS

    Softwareversionen
    • 0.5.0-1
    • 0.7.3-1
    • 0.7.5-1
    • 0.7.5-1ubuntu0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:24.04:LTS

    Softwareversionen
    • 0.8.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.10

    Softwareversionen
    • 0.9.8-2
    • 0.9.10-2
    • 0.9.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.04:LTS

    Softwareversionen
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →