CVE-2026-86062
CVE-2026-86062 · LightRAG: Stored Cross-Site Scripting (XSS) in the LightRAG WebUI chat/answer renderer via ingested content
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.5, lightrag_webui/src/components/retrieval/ChatMessage.tsx renders answer and thinking content with react-markdown, rehypeRaw, and skipHtml=false without an HTML sanitizer. An attacker who can add a document can store raw HTML that is returned through the query path and rendered as active content by MessageMarkdown. A user who later retrieves the content can execute attacker-controlled JavaScript through elements such as an iframe srcdoc; the additional Mermaid securityLevel: loose rendering path also injects generated SVG through innerHTML. The script runs in the LightRAG WebUI origin and can read the API token in localStorage and perform API actions as the victim. This issue is fixed in version 1.5.5.
CVSS 6.1 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
lightrag
- Softwareversionen
- < 1.5.5: Betroffen
Keine Korrektur veröffentlicht
lightrag-hku PyPI
- Softwareversionen
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- 1.0.0
- 1.0.1
- 1.0.3
- 1.0.5
- 1.0.6
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.5
- 1.2.6
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.4.1
- 1.4.10
- 1.4.11
- 1.4.11rc2
- 1.4.12
- 1.4.12rc1
- 1.4.13
- 1.4.13rc1
- 1.4.14
- 1.4.15
- 1.4.16
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- 1.4.8.1
- 1.4.8.2
- 1.4.8rc4
- 1.4.8rc6
- 1.4.8rc7
- 1.4.8rc8
- 1.4.8rc9
- 1.4.9
- 1.4.9.1
- 1.4.9.10
- 1.4.9.11
- 1.4.9.2
- 1.4.9.3
- 1.4.9.4
- 1.4.9.4rc1
- 1.4.9.5
- 1.4.9.6
- 1.4.9.7
- 1.4.9.8
- 1.4.9.9
- 1.4.9rc1
- 1.4.9rc2
- 1.4.9rc3
- 1.4.9rc4
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.0rc3
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.5
Auf 1.5.5 aktualisieren