CVE-2026-86434
CVE-2026-86434 · commonmark 2.0.0 through 2.8.3 Denial of Service via Slug Collision
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
league/commonmark versions >= 2.0.0 and < 2.8.4 (patched in 2.9.0) contain a denial of service vulnerability in UniqueSlugNormalizer::normalize(), which restarts its numeric-suffix search from 1 on every slug collision, resulting in O(K^2) time complexity for K headings that collapse to the same base slug. The vulnerable path is reached when HeadingPermalinkExtension, FootnoteExtension, or TableOfContentsExtension is registered. An unauthenticated attacker can force many headings onto a single base slug (e.g., via empty ATX headings, identical heading text, or punctuation-only headings) in a small Markdown document, consuming excessive CPU and denying service.
CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
commonmark
- Softwareversionen
- ≥ 2.0.0, < 2.8.4: Betroffen (semver)
- 2.8.4: Nicht betroffen (semver)
Auf 2.8.4 aktualisieren
php-league-commonmark Debian:12
- Softwareversionen
- 2.10.0-1
- 2.10.1-1
- 2.10.3-1
- 2.3.9-1
- 2.3.9-1+deb12u1
- 2.4.0-1
- 2.4.1-1
- 2.4.2-1
- 2.4.2-2
- 2.5.0-1
- 2.5.1-1
- 2.5.3-1
- 2.6.0-1
- 2.6.1-1
- 2.6.1-2
- 2.6.2-1
- 2.7.0-1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- 2.9.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-league-commonmark Debian:13
- Softwareversionen
- 2.10.0-1
- 2.10.1-1
- 2.10.3-1
- 2.7.0-1
- 2.7.0-1+deb13u1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- 2.9.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-league-commonmark Debian:14
- Softwareversionen
- 2.7.0-1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.9.0-1
Auf 2.9.0-1 aktualisieren
league/commonmark Packagist
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.9.0
Auf 2.9.0 aktualisieren
php-league-commonmark Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.1.2-1
- 1.2.0-1
- 1.3.0-1
- 1.3.1-1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-league-commonmark Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.5.7-2build1
- 1.6.6-1build1
- 1.6.7-1
- 1.6.7-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-league-commonmark Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 2.3.9-1
- 2.4.1-1
- 2.4.2-1
- 2.4.2-2
- 2.4.2-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-league-commonmark Ubuntu:26.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.1-2
- 2.8.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht