p PatchFirst

CVE-2026-88058

CVE-2026-88058 · Angular: SSR XSS via Unescaped Processing Instruction (<?...?>) Nodes in Fallback Raw-Content Elements

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.30, 21.2.22, and 22.1.4, Angular server-side rendering (SSR) in @angular/platform-server serializes ProcessingInstruction DOM nodes inside fallback raw-content elements without escaping matching ancestor closing tags. ProcessingInstruction data escaped greater-than characters but left less-than characters untouched and did not inspect fallback ancestors, so data such as a matching closing tag prematurely terminates noscript, iframe, noembed, or noframes containers. The vulnerable nodes cannot be authored through standard Angular templates; reachability requires application or library code using inject(DOCUMENT).createProcessingInstruction with attacker-controlled data or Renderer2 DOM insertion inside a fallback container. In HTML5 RAWTEXT parsing, the premature close causes subsequent sibling elements to be interpreted as live HTML and enables arbitrary JavaScript execution in a victim's browser. This issue is fixed in versions 20.3.30, 21.2.22, and 22.1.4.

CVSS 8.6 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • angular

    Softwareversionen
    • <= 19.2.25: Betroffen
    • >= 20.0.0, < 20.3.30: Betroffen
    • >= 21.0.0, < 21.2.22: Betroffen
    • >= 22.0.0, < 22.1.4: Betroffen

    Keine Korrektur veröffentlicht

  • angular.js Debian:12

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Debian:13

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0, < 22.1.4

    Auf 22.1.4 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0, < 21.2.22

    Auf 21.2.22 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0, < 20.3.30

    Auf 20.3.30 aktualisieren

  • @angular/platform-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 19.2.25

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:24.04:LTS

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.10

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.04:LTS

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →