p PatchFirst

CVE-2026-96286

CVE-2026-96286 · Apache Thrift: Perl servers end `serve()` when serving one connection fails

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Uncaught exception vulnerability in Apache Thrift Perl bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

CVSS 8.2 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache thrift

    Softwareversionen
    • ≥ 0, < 0.25.0: Betroffen (semver)

    Auf 0.25.0 aktualisieren

  • thrift Debian:12

    Softwareversionen
    • 0.17.0-2
    • 0.17.0-3
    • 0.17.0-4
    • 0.18.1-1
    • 0.18.1-2
    • 0.19.0-1
    • 0.19.0-2
    • 0.19.0-2.1
    • 0.19.0-2.1~exp1
    • 0.19.0-3
    • 0.19.0-4
    • 0.20.0-1
    • 0.22.0-1
    • 0.22.0-2
    • 0.22.0-3
    • 0.22.0-4
    • 0.23.0-1
    • 0.23.0-2
    • 0.23.0-3
    • 0.24.0-1
    • 0.24.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Debian:13

    Softwareversionen
    • 0.19.0-4
    • 0.20.0-1
    • 0.22.0-1
    • 0.22.0-2
    • 0.22.0-3
    • 0.22.0-4
    • 0.23.0-1
    • 0.23.0-2
    • 0.23.0-3
    • 0.24.0-1
    • 0.24.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Debian:14

    Softwareversionen
    • 0.19.0-4
    • 0.20.0-1
    • 0.22.0-1
    • 0.22.0-2
    • 0.22.0-3
    • 0.22.0-4
    • 0.23.0-1
    • 0.23.0-2
    • 0.23.0-3
    • 0.24.0-1
    • 0.24.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Ubuntu:20.04:LTS

    Softwareversionen
    • 0.11.0-6
    • 0.13.0-2build1
    • 0.13.0-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Ubuntu:22.04:LTS

    Softwareversionen
    • 0.13.0-6ubuntu1
    • 0.13.0-6ubuntu2
    • 0.13.0-6ubuntu3
    • 0.13.0-7
    • 0.16.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Ubuntu:24.04:LTS

    Softwareversionen
    • 0.17.0-4
    • 0.19.0-2
    • 0.19.0-2build1
    • 0.19.0-2.1build4
    • 0.19.0-2.1build5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Ubuntu:26.10

    Softwareversionen
    • 0.22.0-3ubuntu1
    • 0.23.0-3
    • 0.23.0-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • thrift Ubuntu:26.04:LTS

    Softwareversionen
    • 0.19.0-4build1
    • 0.22.0-3
    • 0.22.0-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →