p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ffmpeg · Seite 4

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ffmpeg: 10. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 418

  1. CVE-2025-59733

    Hoch · CVSS 8.7EPSS 0,18%Korrektur verfügbar

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, there's an implicit assumption that all image channels have the same pixel type (and size), and that if there are four channels, the first four are "B", "G", "R" and "A". The channel parsing code can be found in decode_header. The buffer td->uncompressed_data is allocated in decode_block based on the xsize, ysize and computed current_channel_offset. The function dwa_uncompress then assumes at [5] that if there are 4 channels, these are "B", "G", "R" and "A", and in the calculations at [6] and [7] that all channels are of the same type, which matches the type of the main color

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-59732

    Hoch · CVSS 8.7EPSS 0,19%Korrektur verfügbar

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, there's an implicit assumption that the height and width are divisible by 8. If the height or width of the image is not divisible by 8, the copy loops at [0] and [1] will continue to write until the next multiple of 8. The buffer td->uncompressed_data is allocated in decode_block based on the precise height and width of the image, so the "rounded-up" multiple of 8 in the copy loop can exceed the buffer bounds, and the write block starting at [2] can corrupt following heap memory. We recommend upgrading to version 8.0 or beyond.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2025-59731

    Mittel · CVSS 6.9EPSS 0,17%Korrektur verfügbar

    Heap-buffer-overflow write in FFmpeg EXR dwa_uncompress

    When decoding an OpenEXR file that uses DWAA or DWAB compression, the specified raw length of run-length-encoded data is not checked when using it to calculate the output data. We read rle_raw_size from the input file at [0], we decompress and decode into the buffer td->rle_raw_data of size rle_raw_size at [1], and then at [2] we will access entries in this buffer up to (td->xsize - 1) * (td->ysize - 1) + rle_raw_size / 2, which may exceed rle_raw_size. We recommend upgrading to version 8.0 or beyond.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2025-9951

    Hoch · CVSS 7.2EPSS 0,44%Korrektur verfügbar

    Remote code execution via Heap Buffer Overflow in FFmpeg JPEG2000

    A heap-buffer-overflow write exists in jpeg2000dec FFmpeg which allows an attacker to potentially gain remote code execution or cause denial of service via the channel definition cdef atom of JPEG2000.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2025-1594

    Mittel · CVSS 5.3EPSS 0,6%Korrektur verfügbar

    FFmpeg AAC Encoder aacenc_tns.c ff_aac_search_for_tns stack-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 7.1. This affects the function ff_aac_search_for_tns of the file libavcodec/aacenc_tns.c of the component AAC Encoder. The manipulation leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used.

    • Auf 7:5.1.8-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2025-0518

    Mittel · CVSS 4.8EPSS 0,38%Korrektur verfügbar

    Unchecked sscanf return value which leads to memory data leak

    Unchecked Return Value, Out-of-bounds Read vulnerability in FFmpeg allows Read Sensitive Constants Within an Executable. This vulnerability is associated with program files https://github.Com/FFmpeg/FFmpeg/blob/master/libavfilter/af_pan.C . This issue affects FFmpeg: 7.1. Issue was fixed:  https://github.com/FFmpeg/FFmpeg/commit/b5b6391d64807578ab872dc58fb8aa621dcfc38a https://github.com/FFmpeg/FFmpeg/commit/b5b6391d64807578ab872dc58fb8aa621dcfc38a This issue was discovered by: Simcha Kosman

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2023-6605

    Hoch · CVSS 7.2EPSS 0,37%Korrektur verfügbar

    Ffmpeg: dash playlist ssrf vulnerability in ffmpeg

    A flaw was found in FFmpeg's DASH playlist support. This vulnerability allows arbitrary HTTP GET requests to be made on behalf of the machine running FFmpeg via a crafted DASH playlist containing malicious URLs.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2023-6604

    Mittel · CVSS 5.3EPSS 0,47%Korrektur verfügbar

    Ffmpeg: hls xbin demuxer dos amplification in ffmpeg

    A flaw was found in FFmpeg. This vulnerability allows unexpected additional CPU load and storage consumption, potentially leading to degraded performance or denial of service via the demuxing of arbitrary data as XBIN-formatted data without proper format validation.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2023-6603

    Hoch · CVSS 7.5EPSS 0,58%Korrektur verfügbar

    Ffmpeg: null pointer dereference in ffmpeg hls parsing

    A flaw was found in FFmpeg's HLS playlist parsing. This vulnerability allows a denial of service via a maliciously crafted HLS playlist that triggers a null pointer dereference during initialization.

    • Auf 7:5.0.1-2 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2024-35369

    Mittel · CVSS 5.5EPSS 0,24%Keine Korrektur veröffentlicht

    CVE-2024-35369

    In FFmpeg version n6.1.1, specifically within the avcodec/speexdec.c module, a potential security vulnerability exists due to insufficient validation of certain parameters when parsing Speex codec extradata. This vulnerability could lead to integer overflow conditions, potentially resulting in undefined behavior or crashes during the decoding process.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →