p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ffmpeg · Seite 5

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ffmpeg: 10. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 418

  1. CVE-2024-35366

    Kritisch · CVSS 9.1EPSS 0,65%Korrektur verfügbar

    CVE-2024-35366

    FFmpeg n6.1.1 is Integer Overflow. The vulnerability exists in the parse_options function of sbgdec.c within the libavformat module. When parsing certain options, the software does not adequately validate the input. This allows for negative duration values to be accepted without proper bounds checking.

    • Auf 7:5.1.5-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2024-7272

    Mittel · CVSS 6.9EPSS 1,2%Korrektur verfügbar

    FFmpeg swresample.c fill_audiodata heap-based overflow

    A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

    • Auf 7:5.1.6-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-7055

    Mittel · CVSS 6.9EPSS 1,44%Korrektur verfügbar

    FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

    A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

    • Auf 7:5.1.6-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2023-51794

    Hoch · CVSS 7.8EPSS 0,22%Korrektur verfügbar

    CVE-2023-51794

    Buffer Overflow vulnerability in Ffmpeg v.N113007-g8d24a28d06 allows a local attacker to execute arbitrary code via the libavfilter/af_stereowiden.c:120:69.

    • Auf 7:5.1.5-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2024-31582

    Hoch · CVSS 7.8EPSS 0,34%Korrektur verfügbar

    CVE-2024-31582

    FFmpeg version n6.1 was discovered to contain a heap buffer overflow vulnerability in the draw_block_rectangle function of libavfilter/vf_codecview.c. This vulnerability allows attackers to cause undefined behavior or a Denial of Service (DoS) via crafted input.

    • Auf 7:5.1.7-0+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →