p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in php-phpseclib

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für php-phpseclib: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 11

  1. CVE-2026-55599

    Mittel · CVSS 5.8EPSS 0,21%Keine Korrektur veröffentlicht

    phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access

    phpseclib is a PHP secure communications library. From 0.1.1 until 1.0.30, 2.0.55, and 3.0.54, when an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 16

    Veröffentlicht Aktualisiert
  2. CVE-2026-44167

    Hoch · CVSS 7.5EPSS 0,2%Korrektur verfügbar

    phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

    phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

    • Auf 2.0.42-1+deb12u5 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-40194

    Niedrig · CVSS 3.7EPSS 0,36%Korrektur verfügbar

    phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()

    phpseclib is a PHP secure communications library. Starting in 0.1.1 and prior to 3.0.51, 2.0.53, and 1.0.28, phpseclib\Net\SSH2::get_binary_packet() uses PHP's != operator to compare a received SSH packet HMAC against the locally computed HMAC. != on equal-length binary strings in PHP uses memcmp(), which short-circuits on the first differing byte. This is a real variable-time comparison (CWE-208), proven by scaling benchmarks. This vulnerability is fixed in 3.0.51, 2.0.53, and 1.0.28.

    • Auf 2.0.42-1+deb12u4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-32935

    Hoch · CVSS 8.2EPSS 0,39%Korrektur verfügbar

    phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

    phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

    • Auf 2.0.42-1+deb12u3 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2023-52892

    Hoch · CVSS 7.5EPSS 0,38%Korrektur verfügbar

    CVE-2023-52892

    In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.

    • Auf 2.0.42-1+deb12u3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2024-27355

    Hoch · CVSS 7.5EPSS 0,57%Korrektur verfügbar

    CVE-2024-27355

    An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).

    • Auf 2.0.42-1+deb12u2 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2024-27354

    Hoch · CVSS 7.5EPSS 0,6%Korrektur verfügbar

    CVE-2024-27354

    An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

    • Auf 2.0.42-1+deb12u2 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2023-48795

    Mittel · CVSS 5.9EPSS 93,55%Öffentlicher ExploitKorrektur verfügbar

    CVE-2023-48795

    The SSH transport protocol with certain OpenSSH extensions, found in OpenSSH before 9.6 and other products, allows remote attackers to bypass integrity checks such that some packets are omitted (from the extension negotiation message), and a client and server may consequently end up with a connection for which some security features have been downgraded or disabled, aka a Terrapin attack. This occurs because the SSH Binary Packet Protocol (BPP), implemented by these extensions, mishandles the handshake phase and mishandles use of sequence numbers. For example, there is an effective attack against SSH's use of ChaCha20-Poly1305 (and CBC with E

    • Auf 2.0.42-1+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →