p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in systemd

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für systemd: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 60

  1. CVE-2026-16742

    Mittel · CVSS 6.7EPSS 0,06%Keine Korrektur veröffentlicht

    systemd-homed: local privilege escalation via missing home-record signature verification on the authenticate path

    systemd-homed contains a local privilege escalation bug via arbitrary system group addition to a local, logged in, homed-managed user

    Veröffentlicht Aktualisiert
  2. CVE-2026-15059

    Mittel · CVSS 5.5EPSS 0,12%Keine Korrektur veröffentlicht

    systemd-oomd: unprivileged users can terminate arbitrary processes

    Local unprivileged users can terminate arbitrary local processes via a systemd-oomd IPC API due to a missing path traversal validation.

    Veröffentlicht Aktualisiert
  3. CVE-2026-29111

    Mittel · CVSS 5.5EPSS 0,17%Korrektur verfügbar

    systemd: Local unprivileged user can trigger an assert

    systemd, a system and service manager, (as PID 1) hits an assert and freezes execution when an unprivileged IPC API call is made with spurious data. On version v249 and older the effect is not an assert, but stack overwriting, with the attacker controlled content. From version v250 and newer this is not possible as the safety check causes an assert instead. This IPC call was added in v239, so versions older than that are not affected. Versions 260-rc1, 259.2, 258.5, and 257.11 contain patches. No known workarounds are available.

    • Auf 252.39-1~deb12u2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-4105

    Mittel · CVSS 6.7EPSS 0,15%Korrektur verfügbar

    Systemd: systemd: privilege escalation via improper access control in registermachine d-bus method

    A flaw was found in systemd. The systemd-machined service contains an Improper Access Control vulnerability due to insufficient validation of the class parameter in the RegisterMachine D-Bus (Desktop Bus) method. A local unprivileged user can exploit this by attempting to register a machine with a specific class value, which may leave behind a usable, attacker-controlled machine object. This allows the attacker to invoke methods on the privileged object, leading to the execution of arbitrary commands with root privileges on the host system.

    • Auf 252.39-1~deb12u2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2025-4598

    Mittel · CVSS 4.7EPSS 1,23%Korrektur verfügbar

    Systemd-coredump: race condition that allows a local attacker to crash a suid program and gain read access to the resulting core dump

    A vulnerability was found in systemd-coredump. This flaw allows an attacker to force a SUID process to crash and replace it with a non-SUID binary to access the original's privileged process coredump, allowing the attacker to read sensitive data, such as /etc/shadow content, loaded by the original process. A SUID binary or process has a special type of permission, which allows the process to run with the file owner's permissions, regardless of the user executing the binary. This allows the process to access more restricted data than unprivileged users or processes would be able to. An attacker can leverage this flaw by forcing a SUID process

    • Auf 252.38-1~deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2023-50868

    Hoch · CVSS 7.5EPSS 74,3%Korrektur verfügbar

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 252.23-1~deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2023-50387

    Hoch · CVSS 7.5EPSS 99,99%Korrektur verfügbar

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 252.23-1~deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2023-7008

    Mittel · CVSS 5.9EPSS 0,85%Korrektur verfügbar

    Systemd-resolved: unsigned name response in signed zone is not refused when dnssec=yes

    A vulnerability was found in systemd-resolved. This issue may allow systemd-resolved to accept records of DNSSEC-signed domains even when they have no signature, allowing man-in-the-middles (or the upstream DNS resolver) to manipulate records.

    • Auf 252.21-1~deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2023-31439

    Mittel · CVSS 5.3EPSS 0,35%Keine Korrektur veröffentlicht

    CVE-2023-31439

    An issue was discovered in systemd 253. An attacker can modify the contents of past events in a sealed log file and then adjust the file such that checking the integrity shows no error, despite modifications. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

    Veröffentlicht Aktualisiert
  10. CVE-2023-31438

    Mittel · CVSS 5.3EPSS 0,33%Keine Korrektur veröffentlicht

    CVE-2023-31438

    An issue was discovered in systemd 253. An attacker can truncate a sealed log file and then resume log sealing such that checking the integrity shows no error, despite modifications. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

    Veröffentlicht Aktualisiert
  11. CVE-2023-31437

    Mittel · CVSS 5.3EPSS 0,34%Keine Korrektur veröffentlicht

    CVE-2023-31437

    An issue was discovered in systemd 253. An attacker can modify a sealed log file such that, in some views, not all existing and sealed log messages are displayed. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."

    Veröffentlicht Aktualisiert
  12. CVE-2023-26604

    Hoch · CVSS 7.8EPSS 1,05%Korrektur verfügbar

    CVE-2023-26604

    systemd before 247 does not adequately block local privilege escalation for some Sudo configurations, e.g., plausible sudoers files in which the "systemctl status" command may be executed. Specifically, systemd does not set LESSSECURE to 1, and thus other programs may be launched from the less program. This presents a substantial security risk when running systemctl from Sudo, because less executes as root when the terminal size is too small to show the complete systemctl output.

    • Auf 247.1-2 aktualisieren
    Veröffentlicht Aktualisiert
  13. CVE-2022-45873

    Mittel · CVSS 5.5EPSS 0,27%Korrektur verfügbar

    CVE-2022-45873

    systemd 250 and 251 allows local users to achieve a systemd-coredump deadlock by triggering a crash that has a long backtrace. This occurs in parse_elf_object in shared/elf-util.c. The exploitation methodology is to crash a binary calling the same function recursively, and put it in a deeply nested directory to make its backtrace large enough to cause the deadlock. This must be done 16 times when MaxConnections=16 is set for the systemd/units/systemd-coredump.socket file.

    • Auf 252-1 aktualisieren
    Veröffentlicht Aktualisiert
  14. CVE-2022-2526

    Kritisch · CVSS 9.8EPSS 1,33%Korrektur verfügbar

    CVE-2022-2526

    A use-after-free vulnerability was found in systemd. This issue occurs due to the on_stream_io() function and dns_stream_complete() function in 'resolved-dns-stream.c' not incrementing the reference counting for the DnsStream object. Therefore, other functions and callbacks called can dereference the DNSStream object, causing the use-after-free when the reference is still used later.

    • Auf 240-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →