p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in pcre2

In den letzten 30 Tagen veröffentlichte Sicherheitslücke für pcre2: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 16

  1. CVE-2026-86145

    Hoch · CVSS 8.2EPSS 0,43%Korrektur verfügbar

    CVE-2026-86145

    PCRE2 before 10.48 allows a pcre2_dfa_match out-of-bounds write because reuse of a cached workspace block, in a recursive DFA matching workspace, lacks a size check (even though a newly allocated block, for the same purpose, does have a size check). This outcome requires an attacker-controlled regular expression, or a recursive pattern in conjunction with a small heap limit (this can be set through the API).

    • Auf 10.46-1~deb13u2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-58050

    Mittel · CVSS 6.9EPSS 0,83%Korrektur verfügbar

    PCRE2: heap-buffer-overflow read in match_ref due to missing boundary restoration in SCS

    The PCRE2 library is a set of C functions that implement regular expression pattern matching. In version 10.45, a heap-buffer-overflow read vulnerability exists in the PCRE2 regular expression matching engine, specifically within the handling of the (*scs:...) (Scan SubString) verb when combined with (*ACCEPT) in src/pcre2_match.c. This vulnerability may potentially lead to information disclosure if the out-of-bounds data read during the memcmp affects the final match result in a way observable by the attacker. This issue has been resolved in version 10.46.

    • Auf 10.46-1~deb13u1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-1587

    Kritisch · CVSS 9.1EPSS 2,77%Korrektur verfügbar

    CVE-2022-1587

    An out-of-bounds read vulnerability was discovered in the PCRE2 library in the get_recurse_data_length() function of the pcre2_jit_compile.c file. This issue affects recursions in JIT-compiled regular expressions caused by duplicate data transfers.

    • Auf 10.40-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-1586

    Kritisch · CVSS 9.1EPSS 3,37%Korrektur verfügbar

    CVE-2022-1586

    An out-of-bounds read vulnerability was discovered in the PCRE2 library in the compile_xclass_matchingpath() function of the pcre2_jit_compile.c file. This involves a unicode property matching issue in JIT-compiled regular expressions. The issue occurs because the character was not fully read in case-less matching within JIT.

    • Auf 10.40-1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-20454

    Mittel · CVSS 5.1EPSS 1,56%Korrektur verfügbar

    CVE-2019-20454

    An out-of-bounds read was discovered in PCRE before 10.34 when the pattern \X is JIT compiled and used to match specially crafted subjects in non-UTF mode. Applications that use PCRE to parse untrusted input may be vulnerable to this flaw, which would allow an attacker to crash the application. The flaw occurs in do_extuni_no_utf in pcre2_jit_compile.c.

    • Auf 10.34-1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2016-3191

    Kritisch · CVSS 9.8EPSS 8,43%Korrektur verfügbar

    CVE-2016-3191

    The compile_branch function in pcre_compile.c in PCRE 8.x before 8.39 and pcre2_compile.c in PCRE2 before 10.22 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.

    • Auf 10.21-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →