p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in thrift · Seite 4

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für thrift: 61. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 91

  1. CVE-2026-94635

    Hoch · CVSS 8.7EPSS 0,34%Keine Korrektur veröffentlicht

    Apache Thrift: Lua `TBinaryProtocol:readMessageBegin` bypasses `checkStringSize` on the pre-versioned name

    Allocation of resources without limits or throttling, Improper handling of length parameter inconsistency vulnerability in Apache Thrift Lua bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  2. CVE-2026-66053

    Mittel · CVSS 5.9EPSS 0,29%Keine Korrektur veröffentlicht

    Apache Thrift: Python TSSLSocket Hostname Matcher Import

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

    Veröffentlicht Aktualisiert
  3. CVE-2026-58662

    Hoch · CVSS 8.7EPSS 1,08%Keine Korrektur veröffentlicht

    Apache Thrift: C++ THeaderTransport::readString() info-header length bounds bypass

    Improper Validation of Specified Quantity in Input, Out-of-bounds Read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  4. CVE-2026-58389

    Hoch · CVSS 8.7EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Rust binary protocol non-strict path missing string size limit

    Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Rust bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  5. CVE-2026-55971

    Kritisch · CVSS 9.3EPSS 0,98%Keine Korrektur veröffentlicht

    Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform()

    Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  6. CVE-2026-55969

    Hoch · CVSS 8.7EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: integer overflow in TProtocol::checkReadBytesAvailable()

    Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  7. CVE-2026-55968

    Hoch · CVSS 8.7EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Node.js quadratic-time DoS in server receive transports

    Inefficient Algorithmic Complexity, Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Node.js bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  8. CVE-2026-49158

    Hoch · CVSS 7.5EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  9. CVE-2026-48586

    Hoch · CVSS 8.7EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TZlibTransport Decompression Size Limit

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  10. CVE-2026-48145

    Hoch · CVSS 8.2EPSS 0,42%Keine Korrektur veröffentlicht

    Apache Thrift: C++ TSSLSocket matchName() RFC 6125 Wildcard Bypass

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  11. CVE-2026-48144

    Kritisch · CVSS 9.1EPSS 0,4%Keine Korrektur veröffentlicht

    Apache Thrift: c_glib TLS Client Missing Hostname Verification

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  12. CVE-2026-45112

    Mittel · CVSS 6.9EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Unbounded Read Leading to Denial of Service

    Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: from 0.19.0 before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  13. CVE-2026-43871

    Hoch · CVSS 8.7EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit

    Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  14. CVE-2026-41608

    Hoch · CVSS 7.5EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  15. CVE-2026-43870

    Hoch · CVSS 7.3EPSS 0,38%Keine Korrektur veröffentlicht

    Apache Thrift: Node.js web_server.js multi-vulnerability

    Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →