CVE-2026-41608
CVE-2026-41608 · Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
CVSS 7.5 · Hoch · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
apache thrift
- Softwareversionen
- ≥ 0, < 0.24.0: Betroffen (semver)
Auf 0.24.0 aktualisieren
thrift Debian:12
- Softwareversionen
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Debian:13
- Softwareversionen
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Debian:14
- Softwareversionen
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.24.0-2
Auf 0.24.0-2 aktualisieren
thrift PyPI
- Softwareversionen
- 0.10.0
- 0.11.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.14.2
- 0.15.0
- 0.16.0
- 0.20.0
- 0.21.0
- 0.22.0
- 0.23.0
- 0.8.0
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.24.0
Auf 0.24.0 aktualisieren
thrift Ubuntu:20.04:LTS
- Softwareversionen
- 0.11.0-6
- 0.13.0-2build1
- 0.13.0-2build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:22.04:LTS
- Softwareversionen
- 0.13.0-6ubuntu1
- 0.13.0-6ubuntu2
- 0.13.0-6ubuntu3
- 0.13.0-7
- 0.16.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:24.04:LTS
- Softwareversionen
- 0.17.0-4
- 0.19.0-2
- 0.19.0-2build1
- 0.19.0-2.1build4
- 0.19.0-2.1build5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:26.10
- Softwareversionen
- 0.22.0-3ubuntu1
- 0.23.0-3
- 0.23.0-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:26.04:LTS
- Softwareversionen
- 0.19.0-4build1
- 0.22.0-3
- 0.22.0-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht