p PatchFirst

GHSA-2cf5-4w76-r9qv

GHSA-2cf5-4w76-r9qv · Arbitrary Code Execution in handlebars

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Versions of `handlebars` prior to 3.0.8 or 4.5.2 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). The following template can be used to demonstrate the vulnerability: ```{{#with "constructor"}} {{#with split as |a|}} {{pop (push "alert('Vulnerable Handlebars JS');")}} {{#with (concat (lookup join (slice 0 1)))}} {{#each (slice 2 3)}} {{#with (apply 0 a)}} {{.}} {{/with}} {{/each}} {{/with}} {{/with}} {{/with}}``` ## Recommendation Upgrade to version 3.0.8, 4.5.2 or later.

CVSS 7.3 · Hoch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • handlebars npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.0.8

    Auf 3.0.8 aktualisieren

  • handlebars npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.5.2

    Auf 4.5.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →