GHSA-9qr9-h5gf-34mp
GHSA-9qr9-h5gf-34mp · Next.js is vulnerable to RCE in React flight protocol
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability affects certain React packages<sup>1</sup> for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55182](https://www.cve.org/CVERecord?id=CVE-2025-55182). Fixed in: React: 19.0.1, 19.1.2, 19.2.1 Next.js: 15.0.5, 15.1.9, 15.2.6, 15.3.6, 15.4.8, 15.5.7, 16.0.7, 15.6.0-canary.58, 16.1.0-canary.12+ The vulnerability also affects experimental canary releases starting with 14.3.0-canary.77. Users on any of the 14.3 canary builds should either downgrade to a 14.x stable release or 14.3.0-canary.76. All users of stable 15.x or 16.x Next.js versions should upgrade to a patched, stable version immediately. <sup>1</sup> The affected React packages are: - react-server-dom-parcel - react-server-dom-turbopack - react-server-dom-webpack
CVSS 10.0 · Kritisch · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 14.3.0-canary.77, < 15.0.5
Auf 15.0.5 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.1.0-canary.0, < 15.1.9
Auf 15.1.9 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.2.0-canary.0, < 15.2.6
Auf 15.2.6 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.3.0-canary.0, < 15.3.6
Auf 15.3.6 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.4.0-canary.0, < 15.4.8
Auf 15.4.8 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.5.0-canary.0, < 15.5.7
Auf 15.5.7 aktualisieren
next npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 16.0.0-canary.0, < 16.0.7
Auf 16.0.7 aktualisieren
Originalquellen
- https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r
- https://github.com/vercel/next.js/security/advisories/GHSA-9qr9-h5gf-34mp
- https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-fmh4-wr37-44fp
- https://nvd.nist.gov/vuln/detail/CVE-2025-55182
- https://github.com/vercel/next.js
- https://osv.dev/vulnerability/GHSA-9qr9-h5gf-34mp