p PatchFirst

GHSA-mgfg-7533-7jf6

GHSA-mgfg-7533-7jf6 · ezsystems/ezplatform-http-cache affected by Breach with Varnish VCL

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

### Impact This is not a vulnerability in the code per se, but included Varnish VCL templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. Please check your web server configuration as well. ### Patches - See "Patched versions". - https://github.com/ezsystems/ezplatform-http-cache/commit/ca8a5cf69b2c14fbec90412aeeef5c755c51457b ### Workarounds Make sure HTTP compression is disabled for REST API requests and other communication that might contain secrets. ### References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes: https://doc.ibexa.co/en/latest/update_and_migration/from_3.3/update_from_3.3/#v3341 - https://github.com/ibexa/post-install/security/advisories/GHSA-4h8f-c635-25p7 - https://github.com/ibexa/http-cache/security/advisories/GHSA-fh7v-q458-7vmw - https://www.breachattack.com/

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • ezsystems/ezplatform-http-cache Packagist

    Softwareversionen
    • v0.1.0
    • v0.1.0-rc1
    • v0.1.1
    • v0.1.1-beta1
    • v0.1.1-rc1
    • v0.2.0
    • v0.2.1
    • v0.2.1.1
    • v0.2.2
    • v0.2.3
    • v0.2.4
    • v0.2.5
    • v0.3.0
    • v0.3.0-rc1
    • v0.3.0-rc2
    • v0.3.0-rc3
    • v0.3.0-rc4
    • v0.4.0
    • v0.4.0-beta1
    • v0.4.0-rc1
    • v0.4.1
    • v0.4.1-rc1
    • v0.4.1-rc2
    • v0.4.2
    • v0.4.2-rc2
    • v0.4.2.1
    • v0.4.2.2
    • v0.4.2.3
    • v0.5.0
    • v0.5.0-beta1
    • v0.5.0-rc1
    • v0.5.0-rc2
    • v0.5.0-rc3
    • v0.5.0-rc4
    • v0.6.0
    • v0.6.0-rc1
    • v0.6.0-rc2
    • v0.6.0.1
    • v0.6.0.2
    • v0.6.1
    • v0.6.1-rc1
    • v0.6.1.1
    • v0.7.0
    • v0.7.0-beta1
    • v0.7.0-rc1
    • v0.7.0-rc2
    • v0.7.1-rc1
    • v0.8.0
    • v0.8.0-beta1
    • v0.8.0-rc1
    • v0.8.0-rc2
    • v0.8.1
    • v0.8.2
    • v0.8.3
    • v0.9.0
    • v0.9.0-rc1
    • v0.9.0-rc2
    • v0.9.0-rc3
    • v0.9.1
    • v0.9.1-rc1
    • v0.9.1-rc2
    • v0.9.2
    • v0.9.2-rc1
    • v0.9.2-rc2
    • v0.9.3
    • v0.9.3-rc1
    • v0.9.4
    • v1.0.0
    • v1.0.0-beta1
    • v1.0.0-beta2
    • v1.0.0-beta3
    • v1.0.0-beta4
    • v1.0.0-rc1
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.0.5
    • v1.0.6
    • v2.0.0
    • v2.0.0-beta1
    • v2.0.0-rc1
    • v2.0.1
    • v2.0.2
    • v2.1.0
    • v2.1.0-beta1
    • v2.1.0-rc1
    • v2.1.1
    • v2.1.2
    • v2.1.3
    • v2.1.4
    • v2.2.0
    • v2.2.0-beta1
    • v2.2.0-rc1
    • v2.2.1
    • v2.2.2
    • v2.2.3
    • v2.3.0
    • v2.3.0-beta1
    • v2.3.0-rc1
    • v2.3.0-rc2
    • v2.3.1
    • v2.3.10
    • v2.3.11
    • v2.3.12
    • v2.3.13
    • v2.3.14
    • v2.3.15
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.3.8
    • v2.3.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.16

    Auf 2.3.16 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →