p PatchFirst

GHSA-r5w7-f542-q2j4

GHSA-r5w7-f542-q2j4 · Potential DoS when using ContextLines integration

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

### Impact The [ContextLines integration](https://docs.sentry.io/platforms/javascript/guides/node/configuration/integrations/contextlines/) uses readable streams to more efficiently use memory when reading files. The ContextLines integration is used to attach source context to outgoing events. The stream was not explicitly closed after use. This could lead to excessive amounts of file handles open on the system and potentially lead to a Denial of Service (DoS). The ContextLines integration is enabled by default in the Node SDK (`@sentry/node`) and SDKs that run in Node.js environments (`@sentry/astro`, `@sentry/aws-serverless`, `@sentry/bun`, `@sentry/google-cloud-serverless`, `@sentry/nestjs`, `@sentry/nextjs`, `@sentry/nuxt`, `@sentry/remix`, `@sentry/solidstart`, `@sentry/sveltekit`). ### Patches Users should upgrade to version `8.49.0` or higher. ### Workarounds To remediate this issue in affected versions without upgrading to version `8.49.0` and above you can disable the ContextLines integration. See the [docs](https://docs.sentry.io/platforms/javascript/guides/node/configuration/integrations/#removing-a-default-integration) for more details. ```js Sentry.init({ // ... integrations: function (integrations) { // integrations will be all default integrations return integrations.filter(function (integration) { return integration.name !== "ContextLines"; }); }, }); ``` If you disable the ContextLines integration, you will lose source context on your error events. ### References - Reported issue: https://github.com/getsentry/sentry-javascript/issues/14892 - PR Fix: https://github.com/getsentry/sentry-javascript/pull/14997

CVSS 3.7 · Niedrig · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • @sentry/node npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/astro npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/aws-serverless npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/bun npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/google-cloud-serverless npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/nestjs npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/nextjs npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/nuxt npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/remix npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/solidstart npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

  • @sentry/sveltekit npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.10.0, < 8.49.0

    Auf 8.49.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →