GHSA-wq8p-mqvg-2p5h
GHSA-wq8p-mqvg-2p5h · laravel framework SQL Injection via limit and offset functions
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: php
Betroffene Produkte und Versionen
laravel/framework Packagist
- Softwareversionen
- v6.0.0
- v6.0.1
- v6.0.2
- v6.0.3
- v6.0.4
- v6.1.0
- v6.10.0
- v6.10.1
- v6.11.0
- v6.12.0
- v6.13.0
- v6.13.1
- v6.14.0
- v6.15.0
- v6.15.1
- v6.16.0
- v6.17.0
- v6.17.1
- v6.18.0
- v6.18.1
- v6.18.10
- v6.18.11
- v6.18.12
- v6.18.13
- v6.18.14
- v6.18.15
- v6.18.16
- v6.18.17
- v6.18.18
- v6.18.19
- v6.18.2
- v6.18.20
- v6.18.21
- v6.18.22
- v6.18.23
- v6.18.24
- v6.18.25
- v6.18.26
- v6.18.27
- v6.18.28
- v6.18.29
- v6.18.3
- v6.18.30
- v6.18.31
- v6.18.32
- v6.18.33
- v6.18.34
- v6.18.35
- v6.18.36
- v6.18.37
- v6.18.38
- v6.18.39
- v6.18.4
- v6.18.40
- v6.18.41
- v6.18.42
- v6.18.43
- v6.18.5
- v6.18.6
- v6.18.7
- v6.18.8
- v6.18.9
- v6.19.0
- v6.19.1
- v6.2.0
- v6.20.0
- v6.20.1
- v6.20.10
- v6.20.11
- v6.20.12
- v6.20.13
- v6.20.14
- v6.20.15
- v6.20.16
- v6.20.17
- v6.20.18
- v6.20.19
- v6.20.2
- v6.20.20
- v6.20.21
- v6.20.22
- v6.20.23
- v6.20.24
- v6.20.25
- v6.20.3
- v6.20.4
- v6.20.5
- v6.20.6
- v6.20.7
- v6.20.8
- v6.20.9
- v6.3.0
- v6.4.0
- v6.4.1
- v6.5.0
- v6.5.1
- v6.5.2
- v6.6.0
- v6.6.1
- v6.6.2
- v6.7.0
- v6.8.0
- v6.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 6.0.0, < 6.20.26
Auf 6.20.26 aktualisieren
laravel/framework Packagist
- Softwareversionen
- v7.0.0
- v7.0.1
- v7.0.2
- v7.0.3
- v7.0.4
- v7.0.5
- v7.0.6
- v7.0.7
- v7.0.8
- v7.1.0
- v7.1.1
- v7.1.2
- v7.1.3
- v7.10.0
- v7.10.1
- v7.10.2
- v7.10.3
- v7.11.0
- v7.12.0
- v7.13.0
- v7.14.0
- v7.14.1
- v7.15.0
- v7.16.0
- v7.16.1
- v7.17.0
- v7.17.1
- v7.17.2
- v7.18.0
- v7.19.0
- v7.19.1
- v7.2.0
- v7.2.1
- v7.2.2
- v7.20.0
- v7.21.0
- v7.22.0
- v7.22.1
- v7.22.2
- v7.22.3
- v7.22.4
- v7.23.0
- v7.23.1
- v7.23.2
- v7.24.0
- v7.25.0
- v7.26.0
- v7.26.1
- v7.27.0
- v7.28.0
- v7.28.1
- v7.28.2
- v7.28.3
- v7.28.4
- v7.29.0
- v7.29.1
- v7.29.2
- v7.29.3
- v7.3.0
- v7.30.0
- v7.30.1
- v7.30.2
- v7.30.3
- v7.30.4
- v7.4.0
- v7.5.0
- v7.5.1
- v7.5.2
- v7.6.0
- v7.6.1
- v7.6.2
- v7.7.0
- v7.7.1
- v7.8.0
- v7.8.1
- v7.9.0
- v7.9.1
- v7.9.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 7.0.0, < 7.30.5
Auf 7.30.5 aktualisieren
laravel/framework Packagist
- Softwareversionen
- v8.0.0
- v8.0.1
- v8.0.2
- v8.0.3
- v8.0.4
- v8.1.0
- v8.10.0
- v8.11.0
- v8.11.1
- v8.11.2
- v8.12.0
- v8.12.1
- v8.12.2
- v8.12.3
- v8.13.0
- v8.14.0
- v8.15.0
- v8.16.0
- v8.16.1
- v8.17.0
- v8.17.1
- v8.17.2
- v8.18.0
- v8.18.1
- v8.19.0
- v8.2.0
- v8.20.0
- v8.20.1
- v8.21.0
- v8.22.0
- v8.22.1
- v8.23.0
- v8.23.1
- v8.24.0
- v8.25.0
- v8.26.0
- v8.26.1
- v8.27.0
- v8.28.0
- v8.28.1
- v8.29.0
- v8.3.0
- v8.30.0
- v8.30.1
- v8.31.0
- v8.32.0
- v8.32.1
- v8.33.0
- v8.33.1
- v8.34.0
- v8.35.0
- v8.35.1
- v8.36.0
- v8.36.1
- v8.36.2
- v8.37.0
- v8.38.0
- v8.39.0
- v8.4.0
- v8.5.0
- v8.6.0
- v8.7.0
- v8.7.1
- v8.8.0
- v8.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 8.0.0, < 8.40.0
Auf 8.40.0 aktualisieren