p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in org.apache.spark:spark-core_2.13

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für org.apache.spark:spark-core_2.13: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2026-32773

    Mittel · CVSS 6.1EPSS 0,41%Korrektur verfügbar

    Apache Spark: XSS Vulnerability in Spark Web 3.5.4

    There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

    • Auf 3.5.8 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-22946

    Mittel · CVSS 6.4EPSS 1,11%Korrektur verfügbar

    Apache Spark proxy-user privilege escalation from malicious configuration class

    In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

    • Auf 3.3.3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-31777

    Mittel · CVSS 5.4EPSS 1,82%Korrektur verfügbar

    Apache Spark XSS vulnerability in log viewer UI Javascript

    A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    • Auf 3.2.2 aktualisieren
    • Auf 3.3.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →