p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in @fastify/express

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für @fastify/express: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2026-33807

    Kritisch · CVSS 9.1EPSS 0,43%Korrektur verfügbar

    @fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes

    @fastify/express v4.0.4 and earlier contains a path handling bug in the onRegister function that causes middleware paths to be doubled when inherited by child plugins. When a child plugin is registered with a prefix that matches a middleware path, the middleware path is prefixed a second time, causing it to never match incoming requests. This results in complete bypass of Express middleware security controls, including authentication, authorization, and rate limiting, for all routes defined within affected child plugin scopes. No special configuration or request crafting is required. Upgrade to @fastify/express v4.0.5 or later.

    • Auf 4.0.5 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-33808

    Kritisch · CVSS 9.1EPSS 0,48%Korrektur verfügbar

    @fastify/express vulnerable to middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)

    Impact@fastify/express v4.0.4 and earlier fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via duplicate slashes when ignoreDuplicateSlashes is enabled, or via semicolon delimiters when useSemicolonDelimiter is enabled. In both cases, Fastify router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. An unauthenticated attacker can access protected routes by manipulating the URL path. PatchesUpgr

    • Auf 4.0.5 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-22037

    Hoch · CVSS 8.4EPSS 0,35%Korrektur verfügbar

    @fastify/express vulnerable to Improper Handling of URL Encoding (Hex Encoding)

    The @fastify/express plugin adds full Express compatibility to Fastify. A security vulnerability exists in @fastify/express prior to version 4.0.3 where middleware registered with a specific path prefix can be bypassed using URL-encoded characters (e.g., `/%61dmin` instead of `/admin`). While the middleware engine fails to match the encoded path and skips execution, the underlying Fastify router correctly decodes the path and matches the route handler, allowing attackers to access protected endpoints without the middleware constraints. The vulnerability is caused by how @fastify/express matches requests against registered middleware paths. Th

    • Auf 4.0.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →