p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in http-proxy-middleware

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für http-proxy-middleware: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-55603

    Hoch · CVSS 7.5EPSS 0,29%Korrektur verfügbar

    http-proxy-middleware: multipart/form-data field injection via unescaped CRLF in `fixRequestBody`

    http-proxy-middleware is node.js http-proxy middleware. From 3.0.4 until 3.0.7 and 4.1.1, fixRequestBody() is the library's documented helper for re-emitting a request body that was already consumed by a body parser. When the outgoing Content-Type is multipart/form-data, it rebuilds the body with handlerFormDataBodyData(), which interpolates each req.body key and value directly into the multipart wire format without neutralizing CR/LF. A \r\n inside a value (or key) lets an attacker close the current part and inject an entirely new form part. Because the proxy's own body parser saw a single opaque value, any gateway-side policy or validation

    • Auf 3.0.7 aktualisieren
    • Auf 4.1.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-55602

    Mittel · CVSS 6.9EPSS 0,38%Korrektur verfügbar

    http-proxy-middleware `router` host+path substring matching allows Host-header-driven backend routing bypass

    http-proxy-middleware is node.js http-proxy middleware. From 0.16.0 until 2.0.10, 3.0.6, and 4.1.0, http-proxy-middleware documents router proxy-table entries as host, path, or host+path selectors, but the host+path implementation uses unanchored substring matching on attacker-controlled request metadata. As a result, a crafted Host header that is only a superstring match for a configured host+path key can still route a request to an unintended backend. This vulnerability is fixed in 2.0.10, 3.0.6, and 4.1.0.

    • Auf 2.0.10 aktualisieren
    • Auf 3.0.6 aktualisieren
    • Auf 4.1.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-21536

    Hoch · CVSS 8.7EPSS 1,03%Korrektur verfügbar

    CVE-2024-21536

    Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.

    • Auf 2.0.7 aktualisieren
    • Auf 3.0.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →