p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in simple-git

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für simple-git: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 10

  1. CVE-2026-102828

    Kritisch · CVSS 9.2EPSS 0,37%Korrektur verfügbar

    simple-git unsafe-operation guard does not block trailer command configuration

    simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

    • Auf 4.0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-102827

    Hoch · CVSS 8.1EPSS 0,58%Korrektur verfügbar

    simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)

    simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clon

    • Auf 4.0.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-102826

    Hoch · CVSS 8.1EPSS 0,46%Öffentlicher ExploitKorrektur verfügbar

    simple-git allows command execution through unblocked Git configuration includes

    simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin does not completely reject configuration includes supplied through customArgs to git.clone(). The missing include.path classification permits Git to load an attacker-controlled configuration file, and the initial remediation does not cover includeIf.<condition>.path, allowing the same file-loading primitive through a conditional include. A loaded configuration can set an executable Git option such as core.sshCommand, which Git invokes during the cl

    • Auf 4.0.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-6951

    Kritisch · CVSS 9.2EPSS 0,88%Öffentlicher ExploitKorrektur verfügbar

    CVE-2026-6951

    Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.

    • Auf 3.36.0 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-28291

    Hoch · CVSS 8.1EPSS 0,77%Korrektur verfügbar

    simple-git has Command Execution via Option-Parsing Bypass

    simple-git enables running native Git commands from JavaScript. Versions up to and including 3.31.1 allow execution of arbitrary commands through Git option manipulation, bypassing safety checks meant to block dangerous options like -u and --upload-pack. The flaw stems from an incomplete fix for CVE-2022-25860, as Git's flexible option parsing allows numerous character combinations (e.g., -vu, -4u, -nu) to circumvent the regular-expression-based blocklist in the unsafe operations plugin. Due to the virtually infinite number of valid option variants that Git accepts, a complete blocklist-based mitigation may be infeasible without fully emulati

    • Auf 3.32.0 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2026-28292

    Kritisch · CVSS 9.8EPSS 1,35%Korrektur verfügbar

    simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE

    `simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.

    • Auf 3.32.3 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2022-25860

    Hoch · CVSS 8.1EPSS 2,71%Korrektur verfügbar

    CVE-2022-25860

    Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution (RCE) via the clone(), pull(), push() and listRemote() methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221).

    • Auf 3.16.0 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2022-25912

    Hoch · CVSS 8.1EPSS 3,08%Korrektur verfügbar

    Remote Code Execution (RCE)

    The package simple-git before 3.15.0 are vulnerable to Remote Code Execution (RCE) when enabling the ext transport protocol, which makes it exploitable via clone() method. This vulnerability exists due to an incomplete fix of [CVE-2022-24066](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2434306).

    • Auf 3.15.0 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2022-24066

    Hoch · CVSS 8.1EPSS 3,9%Korrektur verfügbar

    Command Injection

    The package simple-git before 3.5.0 are vulnerable to Command Injection due to an incomplete fix of [CVE-2022-24433](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199) which only patches against the git fetch attack vector. A similar use of the --upload-pack feature of git is also supported for git clone, which the prior fix didn't cover.

    • Auf 3.5.0 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2022-24433

    Hoch · CVSS 8.1EPSS 3,71%Korrektur verfügbar

    Command Injection

    The package simple-git before 3.3.0 are vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options it was possible to get arbitrary command execution.

    • Auf 3.3.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →